2 Replies Latest reply on May 10, 2006 7:03 AM by Thomas Diesler

    Issue with JBoss 4.0.1- Axis1.2

    test test Newbie

      Hi,

      I am using Axis 1.2 for my program to interface with the 3rd party(with webservices). When i tested that standlone program,it worked fine.Then i tried calling that program from a servlet which is in my application.We use Jboss-4.0.1sp1.We have few webservices enabled on Jboss server.

      Once the server starts,when i try to invoke the servlet which calls my program,it started giving the following weired exception.i think it might be because of Jboss might be using a different version of Axis and i am using Axis1.2 for this program.

      java.lang.NoSuchMethodError: org.apache.axis.description.OperationDesc.setStyle(Lorg/apache/axis/constants/Style;)V

      at TestSoapService_pkg.TestSoapServiceSoapBindingStub._initOperationDesc1(TestSoapServiceSoapBindingStub.java:37)


      So,i tried putting the Axis.1.2 jars in the "jboss-4.0.1sp1\lib\endorsed" and started the server,but this time the webservices that are supposed to run on the servers were not deployed..it gave an exception.I amnot sure how i can make both the programs work.Is there anyay i can tell the Jboss to use its Axis for the webservices and use Axis1.2 for make my program work....

      It will be great if somebody can help me in this,i am new to Jboss and Axis.This is very urgent....

      Thanks