0 Replies Latest reply on Apr 14, 2006 1:33 PM by catfishtyphoon

    complex type mapping in 4.0.3

    catfishtyphoon Newbie

      From the wiki:

      When generating the wsdd, JBossWS4EE looks for additional META-INF/ws4ee-deployment.xml descriptor and when found merges the operations and type mappings with the generated wsdd. For java service endpoints this descriptor should be located in WEB-INF/ws4ee-deployment.xml.

      So, I have a type mapping just like from the wiki in my ws4ee-deployment.xml, and I included that file in the WEB-INF of my war AND I tried putting it in the META-INF of my war (as you can see I don't really understand the quote above), but in either case I still get a
      No serializer found for class com.internap.webdns.User in registry org.jboss.axis.encoding.TypeMappingImpl@4b7b1

      exception when I try to serialize a bean across the web service.

      Where exactly does the ws4ee xml file go? I don't need this file to be referenced in the wscomiple or wsdeploy steps, right, I mean it's a jboss thing?

      is there somewhere else I need to refer to my own complex types? It looks like this should be it, but somehow it's not being picked up by the web service registry.