1 Reply Latest reply on Apr 29, 2006 8:47 AM by Thomas Diesler

    can not open the WSDL in a Deployed web service

    Vincent Yu Newbie

      Dear all,

      I finished a JAXRPC based web service, packaged a war file and then using WSDEPLOY to produce a new war file. The new war file was deployed to JBoss 4.0.4 and everything seemed to be fine. But when I tried to open the url, the page displayed many question marks (not encoding problem, I tried many encodings but no change). The following is a copy from the browser (originally in a table, becomes mess here)


      Web ??
      ??? ?? ??
      MetSoapEndpoint ???
      ??? http://localhost:8080/MyWS/mysoap/MyWSEndpoint
      WSDL? http://localhost:8080/MyWS/mysoap/MyWSEndpoint?WSDL
      ?? QName? {http://www.agmodel.org/Schema/MyWS/2006/02/MyWSEndpoint}MyWSEndpointPort
      ????? net.agmodel.myws.mysoap.jaxrpc.MyWSEndpoint
      ???? net.agmodel.myws.mysoap.MyWSEndpoint_Impl
      ??? http://localhost:8080/MyWS/mysoap/MyWSEndpoint???



      And I tried to open the WSDL by clicking on the above WSDL address, but get the following error message:


      XML Parsing Error: no element found
      Location: http://localhost:8080/MyWS/mysoap/MyWSEndpoint?WSDL
      Line Number 1, Column 39:<?xml version="1.0" encoding="UTF-8"?>
      ----------------------------------


      Anyone can help me?

      Thanks a lot.

      xinwen