5 Replies Latest reply on May 10, 2006 9:57 AM by bmdefnall

    jbossws-samples-1.0.0.GA problem


      i've deployed a plain ejb3 example and now i'm trying to move on to jbossws web services. i downloaded the jbossws-samples-1.0.0.GA zip and unzipped it, now I'm trying to compile with ant.
      i get the following errors:

      [wstools] java.io.IOException: Cannot parse config: Failed to parse source: cvc-complex-type.2.4.a: Invalid content was found starting with element 'java-wsdl'. One of '{"http://www.jboss.org/jbossws-tools":javaToWSDL, "http://www.jboss.org/jbossws-tools":wsdlToJava, "http://www.jboss.org/jbossws-tools":global}' is expected. @ *unknown*[11,14]

      [wstools] Caused by: org.jboss.xb.binding.JBossXBException: Failed to parse source: cvc-complex-type.2.4.a: Invalid content was found starting with element 'java-wsdl'. One of '{"http://www.jboss.org/jbossws-tools":javaToWSDL, "http://www.jboss.org/jbossws-tools":wsdlToJava, "http://www.jboss.org/jbossws-tools":global}' is expected. @ *unknown*[11,14]
       [wstools] at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBParser.java:141)

      and a few more, all dealing with this cvc-complex-type.2.4.a in the error message. I'm not having much luck figuring this out on my own, does anyone have any idea of where to go from here?


        • 1. Re: jbossws-samples-1.0.0.GA problem

          I ran into the same error situation last week, and tracked it down to a problem related to client/jbossws14-client.jar. This file is installed with JBoss 4.0.4 CR2 ejb3 profile (my choice of profile), and includes an out dated version of the schema/jbossws-tool_1_0.xsd that mandates element names like javaToWsdl instead of java-wsdl.

          My solution is to remove the jbossws14-client.jar file from the client directory, and all the sample Web Services compiled without further problems.

          You can also modify the imported-build.xml file to take jbossws14-client.jar out of the compile classpath if you want to.

          Weiqi Gao

          • 2. Re: jbossws-samples-1.0.0.GA problem

            awesome, that worked. thanks much!!

            • 3. Re: jbossws-samples-1.0.0.GA problem

              How were you able to do that?
              Unfortnately the wstool is as well part of the client jar. But if you only delete the xsd from within the jar it works.

              • 4. Re: jbossws-samples-1.0.0.GA problem

                i simply removed jbossws14-client.jar from the $JBOSS_HOME/client directory. i didn't need the java 1.4 version anyway, i'm using 1.5. my common/import-build.xml file still references jbossws-client.jar, just not jbossws14-client.jar. that's all it took.

                • 5. Re: jbossws-samples-1.0.0.GA problem

                  how on earth does everything build properly without the xsd? did you attempt to deploy anything with the xsd missing from the client jar? just curious... oh i removed line 58 of imported-build.xml by the way.