2 Replies Latest reply on May 11, 2006 4:53 AM by Wolfgang Pleus

    wstools emits nothing

    Wolfgang Pleus Newbie

      In the userguide (http://labs.jboss.com/portal/jbossws/user-guide/en/html/getting-started.html) it is states that wstools generates the reqired artifacts to deploy a web service.

      JSR-109 requires a number of deployment artifacts, which are:

      webservices.xml, the descriptor that identifies a deployment a web service endpoint

      wsdl, the abstract webservice contract

      jaxrpc-mapping.xml, the mapping desriptor that bridges wsdl to java


      JBossWS comes with a tool collection called WSTools. WSTools that can generate these artifacts from the given SEI. There is a command line version and an Apache Ant task available. Both take a configuration file as input.


      When I use this tool (commandline and ant based) with my own service implementation nothing is emittet and I get no error message.
      I tried the jsr181pojo example as well with the same result.
      I used the wstools.sh script from the jbossws-1.0.0.GA package.

      Any ideas what to do?