1 Reply Latest reply on May 30, 2006 4:37 PM by Thomas Diesler

    Upgrade from 4.0.4RC2 to 4.0.4.GA-ejb3 brokes running WS

    Werner Jaeger Newbie

      Hello,

      I just upgraded from 4.0.4RC2 to 4.0.4.GA-ejb3.

      Now I get the following exception when deploying an already running application:

      java.io.IOException: org.xml.sax.SAXParseException: The entity name must immediately follow the '&' in the entity reference.


      I could pinpoint line 3 of the following xml fragment as the cause
      <xsd:simpleType name="MailRelayConfiguration">
       <xsd:restriction base="xsd:string">
       <xsd:enumeration value="Incoming & Outgoing"/>
       <xsd:enumeration value="None"/>
       </xsd:restriction>
       </xsd:simpleType>
      


      This lines are in an xml schema file imported by the WSDL.

      The problem is the ampersand entity, which gets expanded to '&' when deploying the WSDL.

      Is this a bug or am I doing somthing wrong ?