1 Reply Latest reply on Jun 29, 2006 9:53 AM by Ole Matzura

    wstools gives UnsupportedClassVersionError: error when run f

    Krishna Chandra Newbie

      I get the following error when I run wstools :

      C:\jboss-4.0.3SP1\client>wstools
      ========================================================================="
      .
      WSTools Environment
      .
      JBOSS_HOME: C:\jboss-4.0.3SP1\client\\..
      .
      JAVA: C:\j2sdk1.4.2_11\bin\java
      .
      JAVA_OPTS:
      .
      ========================================================================="
      .
      Exception in thread "main" java.lang.UnsupportedClassVersionError: org/jboss/ws
      tools/WSTools (Unsupported major.minor version 49.0)
      at java.lang.ClassLoader.defineClass0(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:1
      3)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
      at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
      C:\jboss-4.0.3SP1\client>