0 Replies Latest reply on Jul 14, 2006 12:45 PM by alberto sarubbi

    wstools is working properly?

    alberto sarubbi Newbie

      running wstools generates invalid datatypes when an array was specified in WSDL

      /*
       * JBossWS WS-Tools Generated Source
       *
       * Generation Date: Fri Jul 14 12:29:50 ADT 2006
       * This generated source code represents a derivative work of the
       * input to
       * the generator that produced it. Consult the input for the copyright and
       * terms of use that apply to this source code.
       */
      
      package gov.py.set.services.rucas;
      
      
      public class ClientSystem
      {
      
      protected java.lang.Integer id;
      
      protected java.lang.String name;
      
      protected [Ljava.lang.Byte; password;
      


      should be
      protected java.lang.Byte[] password;



      in some classes, first letter of the method name is not mantained when
      using an uppercase identifier:

      /*
       * JBossWS WS-Tools Generated Source
       *
       * Generation Date: Fri Jul 14 12:29:50 ADT 2006
       *
       * This generated source code represents a derivative work of the input to
       * the generator that produced it. Consult the input for the copyright and
       * terms of use that apply to this source code.
       */
      package gov.py.set.services.rucas;
      public interface SessionManagement extends java.rmi.Remote
      {
      
       public gov.py.set.services.rucas.RUCASConnectResponse rUCASConnect(gov.py.set.services.rucas.AppInfo appInfo,gov.py.set.services.rucas.LoginMethod loginMethod,gov.py.set.services.rucas.CryptMethod cryptMethod) throws java.rmi.RemoteException;



      and finally, jaxrpc-mapping.xml:

      <service-endpoint-method-mapping>
       <java-method-name>rUCASConnect</java-method-name>
       <wsdl-operation>RUCASConnect</wsdl-operation>
       <method-param-parts-mapping>


      all errors are fixable but after every regeneration, needs plumbing...

      don't know if previous messages posted this or resolution status...
      (newbie in jboss web services)

      thanks in advance.