1 Reply Latest reply on Oct 11, 2006 2:49 AM by adeel talib

    jboss does not recognize part accessor with null namespace i

    adeel talib Newbie

      I am invoking a rpc/lit service on apache axis from jboss. I get the following error:

      Caused by: org.jboss.ws.WSException: Content root name does not match element name: getPersonInfoReturn != {http://typespackage}getPersonInfoReturn
      at org.jboss.ws.soap.SOAPContentElement.expandToDOM(SOAPContentElement.java:818)
      at org.jboss.ws.soap.SOAPContentElement.getChildNodes(SOAPContentElement.java:719)
      at org.jboss.util.xml.DOMWriter.printInternal(DOMWriter.java:211)
      at org.jboss.util.xml.DOMWriter.printInternal(DOMWriter.java:270)
      at org.jboss.util.xml.DOMWriter.printInternal(DOMWriter.java:270)
      at org.jboss.util.xml.DOMWriter.printInternal(DOMWriter.java:270)
      at org.jboss.util.xml.DOMWriter.print(DOMWriter.java:186)
      at org.jboss.util.xml.DOMWriter.printNode(DOMWriter.java:135)
      at org.jboss.ws.soap.SOAPConnectionImpl.call(SOAPConnectionImpl.java:193)

      The request message jboss is sending is:

      <env:Body>
      <ns1:getPersonInfo xmlns:ns1='http://typespackage'>
      <in0 xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'>
      123
      12
      adeel
      </in0>
      </ns1:getPersonInfo>
      </env:Body>

      Response message from axis is:

      <soapenv:Body>


      123
      12
      adeel


      </soapenv:Body>

      Is there some problem with the response message?

      Furthermore, as per the WS-I Basic Profile R2735: An ENVELOPE described with an rpc-literal binding MUST place the part accessor elements for parameters and return value in no namespace. Plz See http://ws-i.org/Profiles/BasicProfile-1.1-2004-06-11.html#R2712

      Isn't the request sent by jboss and the response sent by axis voilating WS-I BP?

        • 1. Re: jboss does not recognize part accessor with null namespa
          adeel talib Newbie

          sorry, the correct request and response message are:

          The request message jboss is sending is:

          <env:Body>
           <ns1:getPersonInfo xmlns:ns1='http://typespackage'>
           <in0 xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'>
           <ID>123</ID>
           <age>12</age>
           <name>adeel</name>
           </in0>
           </ns1:getPersonInfo>
           </env:Body>


          Response message from axis is:

          <soapenv:Body>
           <getPersonInfoResponse xmlns='http://typespackage'>
           <getPersonInfoReturn>
           <ID>123</ID>
           <age>12</age>
           <name>adeel</name>
           </getPersonInfoReturn>
           </getPersonInfoResponse>
          </soapenv:Body>