5 Replies Latest reply on Jan 10, 2007 12:22 PM by Ramesh Sridharan

    JBossWS and UDDI

    Markus Reis Newbie

      i tried to setup a UDDI service following the example on http://wiki.jboss.org/wiki/Wiki.jsp?page=UDDIExample; The example works on JBossAS-4.0.3RC2, but does not seem to work with JBossAS-4.0.4GA (although i thought it should do due to the "+" following "JBossAS-4.0.3RC2") - my impression (see also http://jboss.org/jbossBlog/blog/asaldhana/2005/01/19/65E5C15DFCBA5E88EB23FFEC2F2499D7.txt) is that the cause for this is the new WS stack JBossWS (in 4.0.3 it was WS4EE) - is that right?
      And if so, is there already an updated example that works with the JBossWS stack as well?

        • 1. Re: JBossWS and UDDI
          Anil Saldanha Master

          I guess Noel needs to update the example with the new JBossWS stack on JBoss 4.0.4 and above.

          If you want to retain the ws4ee stack on 4.0.4.GA (not recommended),
          http://wiki.jboss.org/wiki/Wiki.jsp?page=JAXROnWS4EEDowngrade

          • 2. Re: JBossWS and UDDI
            Noel Rocher Apprentice

            Hi,

            The part that seems to fail is the service invocation (the final Clent run at the end of the example. All UDDI requests are ok :


            publisher-run:
             [echo] Publish the example ExampleService
             [java] - pulishing :
             [java] uddi inquiry URL = http://localhost:8080/juddi/inquiry
             [java] uddi publish URL = http://localhost:8080/juddi/publish
             [java] uddi user id = jboss
             [java] uddi password =
             [java] wsdl URL = http://localhost:8080/example/ExampleService?wsdl
             [java] business entity = JBoss
             [java] ...
             [java] - Using the Context ClassLoader
             [java] Retrieving document at 'http://localhost:8080/example/ExampleService?wsdl'.
             [java] - creating Business Entity name = JBoss ...
             [java] - No Business Entity "JBoss" found. Will be created.
             [java] - Business Entity "JBoss" created. Key = 29D27B50-666D-11DB-BB50-8D8F32423BEA".
             [java] - creating Business Service ...
             [java] - No Business Service "ExampleService" found. Will be created.
             [java] - Business Service created. Key = 2A057230-666D-11DB-B230-FCC92C392922".
             [java] - Port Type ...
             [java] - PortType Classifications : [org.apache.ws.scout.registry.infomodel.ClassificationImpl@0, org.apache.ws.scout.registry.infomodel.ClassificationImpl@0]
             [java] - No PortType "ExampleService" found. Will be created.
             [java] - Port Type created. Key = uuid:2A13F120-666D-11DB-B120-D46FA9434EFD".
             [java] - creating Binding with portType key = uuid:2A13F120-666D-11DB-B120-D46FA9434EFD ...
             [java] - No Binding "ExampleServiceBinding" found. Will be created.
             [java] - Binding created. Key = uuid:2A1E9F80-666D-11DB-9F80-BE6A5FAB5552".
             [java] - creating Binding Template ...
             [java] - No Service Binding for access point "http://localhost:8080/example/ExampleService" found. Will be created.
             [java] - Service Binding for access point "http://localhost:8080/example/ExampleService" created. Key = 2A2F8F70-666D-11DB-8F70-DF53A4E0575C".
             [java] Done.
            



            the server side is showing this error:

            12:15:01,408 ERROR [SOAPFaultExceptionHelper] SOAP request exception
            javax.xml.rpc.soap.SOAPFaultException: Endpoint {http://org.jboss.example/ExampleService}ExampleServicePort does not contain operation meta data for: {http://schemas.xmlsoap.org/soap/envelope/}Envelope
             at org.jboss.ws.server.ServiceEndpointInvoker.getDispatchDestination(ServiceEndpointInvoker.java:175)
             at org.jboss.ws.server.ServiceEndpointInvoker.invoke(ServiceEndpointInvoker.java:110)
             at org.jboss.ws.server.ServiceEndpoint.handleRequest(ServiceEndpoint.java:234)
             at org.jboss.ws.server.ServiceEndpointServlet.doPost(ServiceEndpointServlet.java:120)
            


            The example code is using JWSDP 1.5 for the WS generation/client invocation. I'm going to try JWSDP 1.6 & JBossWS and I'll tell you more

            • 3. Re: JBossWS and UDDI
              Noel Rocher Apprentice

              mreis : can you tell us what exactly is your error and what is your environment (JDK, JBossWS or JBossWS1.4) ?



              • 4. Re: JBossWS and UDDI
                Ramesh Sridharan Newbie

                Hi

                I am running into the same problem. I am using jboss-4.0.5.GA with JDK 1.5.0. Please help me how to update / upgrade the example so that I can run the client successfully.

                • 5. Re: JBossWS and UDDI
                  Ramesh Sridharan Newbie

                  Noel / Anil, how to upgrade this example to work with Jboss-4.0.5GA. I am getting the same error as Mreis. Please guide.