1 Reply Latest reply on Dec 12, 2006 6:38 AM by Joshua Jackson

    wstools and so

    michel chamoun Newbie

      i m having the following error when i try to generate jbossws artifacts

      Running JBossWS wstools for [IPayment]
      directory: C:\DATA\jboss-4.0.5.GA\bin
      command: cmd.exe /C wstools.bat -config C:\DOCUME~1\MIL~1\LOCALS~1\Temp\wstools-config48758.xml -dest C:\workspace1\TESTWS\TESTWS
      ========================================================================="
      .
       WSTools Environment
      .
       JBOSS_HOME: C:\DATA\jboss-4.0.5.GA\bin\\..
      .
       JAVA: C:\Program Files\Java\jdk1.5.0_09\bin\java
      .
       JAVA_OPTS:
      .
      ========================================================================="
      .
      Exception in thread "main" java.lang.NullPointerException
       at java.io.File.<init>(File.java:194)
       at org.jboss.ws.tools.helpers.ToolsHelper.handleWSDLToJavaGeneration(ToolsHelper.java:282)
       at org.jboss.ws.tools.WSTools.process(WSTools.java:138)
       at org.jboss.ws.tools.WSTools.generate(WSTools.java:120)
       at org.jboss.ws.tools.WSTools.main(WSTools.java:61)
      


      and this is my wstools-config.xml

       <?xml version="1.0" encoding="UTF-8" ?>
      - <jbos:configuration xmlns:jbos="http://www.jboss.org/jbossws-tools">
      - <jbos:wsdl-java file="C:\DOCUME~1\MIL~1\LOCALS~1\Temp\tempdir48759.tmp\PaymentWS.wsdl" unwrap="true">
       <jbos:mapping file="jaxrpc-mapping.xml" />
       </jbos:wsdl-java>
       </jbos:configuration>
      
      


      can someone please help me resolve this error