1 Reply Latest reply on Dec 15, 2006 5:27 AM by Heiko Braun

    JBossWS 1.0.4 compatibility issues with Java SE 6.0?

    ray lai Newbie

      I had the JSR181EJB3 example from JBossWS 1.0.3/1.0.4 running well on JBoss AS 4.0.4/4.0.5 (after some painful patches). After I upgrade my JDK to 6.0, the same example generates the exception UnsupportedOperationException.

      I try to remove the javax.xml.SOAPMessage*.class from the jbossws-client.jar and let the example uses Java SE 6.0's JAX-WS API. but it seems that there are more APIs impacted.

      Java SE 6.0 provides amazing JAXWS 2.0 support. You can use its embedded HTTP web server to publish web services. New JAXWS 2.0 APIs are provided. I'd assume the current JBossWS 1.0.4's JAXWS API is not sync up with the latest JAXWS 2.0 yet.

      similar issue posted at http://www.jboss.org/index.html?module=bb&op=viewtopic&t=95479

      Perhaps JBossWS team can advise the compatibility issue. thanks.