4 Replies Latest reply on Feb 16, 2007 1:26 PM by Dan Liu

    just can't get jbossWS working!!

    Dan Liu Apprentice

      Has anyone managed to get jbossws working with jboss JEMS 1.2.0.GA (downloaded from http://labs.jboss.com/portal/jemsinstaller/downloads).

      Can't get jsr181pojo working with bundled JBossWS 1.0.3.SP1. When I try to upgrad to JBossWS 1.0.4, everything stops working. I just can't see how I can get jbossWS working!!

        • 1. Re: just can't get jbossWS working!!
          Heiko Braun Master

          Make sure you follow the installation instructions from the user guide _and_ the INSTALL.txt that ships with the download.

          • 2. Re: just can't get jbossWS working!!
            Dan Liu Apprentice

            I did follow the instruction. my enviroment:
            Jboss JEMS 1.2 CR1 (AS 4.0.5.GA, EJB3 1.0.0.CR9-jboss4.0.5, Portal 2.4.0.GA, JBossWS 1.0.3.SP1 Installer)

            I downloaded jbossws 1.0.4 and I did:
            1.) Copy lib/jbossws-client.jar to $JBOSS_HOME/client/
            2.) Unzip lib/jbossws.sar to $JBOSS_HOME/server/default/deploy/
            3.) replace the jboss-xml-binding.jar in the $JBOSS_HOME/client and $JBOSS_HOME/lib. (got it from http://repository.jboss.com/jboss/jbossxb/1.0.0.CR7)

            Once I've done everything, I can't even start jboss anymore because clearly jboss depend on the old version of jboss-xml-binding.jar. I've tried many times and I'm sure I did everything right.

            • 3. Re: just can't get jbossWS working!!
              smichea Newbie


              I don't know if this might help but i did the same steps, then added jaxws2.1 in server/default/lib and got into troubles.

              To solve (part of) the problems I had to copy jboss-saaj.jar from client to lib/endorsed

              • 4. Re: just can't get jbossWS working!!
                Dan Liu Apprentice

                Thanks michea. I've tried what you said and now I can start jboss. However, it still doesn't allow me to deploy any simple application.

                Caused by: java.lang.IllegalArgumentException: failed to parse:
                 at java.awt.datatransfer.DataFlavor.<init>(DataFlavor.java:292)
                 at javax.activation.ActivationDataFlavor.<init>(ActivationDataFlavor.java:81)
                 at org.jboss.ws.soap.attachment.ImageDataContentHandler.buildFlavors(ImageDataContentHandler.java:77)
                 at org.jboss.ws.soap.attachment.ImageDataContentHandler.<clinit>(ImageDataContentHandler.java:63)