4 Replies Latest reply on Apr 3, 2007 2:05 PM by Jim Henderson

    I get an "Allocate exception for servlet" error calling my w

    Jim Henderson Newbie

      Hi,

      I have a jax rpc based web service written and tested with jboss-4.0.4.GA which works fine (on aix and windows xp).

      I have just downloaded jboss-4.0.5.GA and am trying my web service on this version and get the following stack trace when the web service is accessed (i have only tried this on windows xp so far)...

      2007-03-07 14:48:32,611 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/dcswebservice-servlet]] Marking servlet DcsWebServiceServlet as unavailable
      2007-03-07 14:48:32,611 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/dcswebservice-servlet].[DcsWebServiceServlet]] Allocate exception for servlet DcsWebServiceServlet
      java.lang.ClassCastException
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1055)
      at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:757)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:130)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
      at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:175)
      at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:74)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
      at org.jboss.web.tomcat.tc5.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:156)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
      at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
      at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
      at java.lang.Thread.run(Thread.java:534)

      Just wondered whether this was a known problem so i can add more information/examples if needed.

      Thanks in advance,

      Jim