3 Replies Latest reply on Mar 30, 2007 9:39 AM by Jason Greene

    StackOverflowError with WS-Security

    Shigemoto Fujikura Newbie

      hi all,

      i'm having a problem when i use ws-security with jbossws.
      when a service implementation returns messages(my own class object or string object) including null value, a StackOverflowError occurs in a client side.

      Exception: java.lang.StackOverflowError
      java.lang.StackOverflowError
      at java.security.AccessController.doPrivileged(Native Method)
      at java.io.PrintWriter.(PrintWriter.java:77)
      at java.io.PrintWriter.(PrintWriter.java:61)
      at org.jboss.ws.utils.DOMWriter.(DOMWriter.java:104)
      at org.jboss.ws.utils.DOMWriter.printNode(DOMWriter.java:141)
      at org.jboss.ws.soap.NodeImpl.assertSOAPParent(NodeImpl.java:592)
      at org.jboss.ws.soap.NodeImpl.getParentNode(NodeImpl.java:296)
      at org.jboss.ws.utils.DOMWriter.getNamespaceURI(DOMWriter.java:435)
      at org.jboss.ws.utils.DOMWriter.getNamespaceURI(DOMWriter.java:438)
      at org.jboss.ws.utils.DOMWriter.getNamespaceURI(DOMWriter.java:438)
      at org.jboss.ws.utils.DOMWriter.printInternal(DOMWriter.java:269)
      at org.jboss.ws.utils.DOMWriter.printInternal(DOMWriter.java:307)
      at org.jboss.ws.utils.DOMWriter.printInternal(DOMWriter.java:307)
      at org.jboss.ws.utils.DOMWriter.print(DOMWriter.java:193)
      at org.jboss.ws.utils.DOMWriter.printNode(DOMWriter.java:141)
      at org.jboss.ws.soap.NodeImpl.assertSOAPParent(NodeImpl.java:592)
      at org.jboss.ws.soap.NodeImpl.getParentNode(NodeImpl.java:296)

      environments:
      jboss 4.0.5
      jbossws 1.0.3 sp1
      service provider(server implementation) and service consumer(client) are running on different machines.

      i tried some different type of object as a return value(return soap message). i found this error occurs if the return string value is null or return object have at least one null value as an attribute.

      in other words, no null values are included in the return value, service invocations are done successfully and i confirmed that the soap messages are correctly encripted.

      does anyone know the reason or workaround?

      best regards,
      shigemoto.