7 Replies Latest reply on Mar 27, 2007 8:09 PM by Ole Matzura

    Problem for publish a Web Service

    Nicolas Arnaud Newbie

      Hy!

      I try to publish a Web Service (with the Eclipse JBoss IDE) with this simple class

      package gen;
      
      import javax.jws.soap.SOAPBinding;
      
      import javax.jws.WebMethod;
      import javax.jws.WebParam;
      import javax.jws.WebService;
      import javax.jws.soap.SOAPBinding;
      
      import org.jboss.ws.annotation.EndpointConfig;
      
      @EndpointConfig(configName = "Standard WSSecurity Endpoint")
      @SOAPBinding(style = SOAPBinding.Style.RPC)
      @javax.jws.WebService(name="HelloImpl", targetNamespace="urn:gen", serviceName="HelloImplService")
      public class HelloImpl implements Hello
      {
      
      @WebMethod
       public String saluer()
       {
       return "Hello ";
       }
      
      }
      


      By when I click on the "generate" button, I have this error:

      Running JBossWS wstools for [testWS]
      directory: D:\workspace\testWS
      command: cmd.exe /C D:\Program Files\Java\jboss-4.0.5.GA\bin\wstools.bat -cp bin -config C:\TEMP\wstools-config22402.xml -dest D:\workspace\testWS\src
      ========================================================================="
      .
       WSTools Environment
      .
       JBOSS_HOME: D:\Program Files\Java\jboss-4.0.5.GA\bin\\..
      .
       JAVA: D:\Program Files\Java\jdk1.5.0_06\bin\java
      .
       JAVA_OPTS:
      .
      ========================================================================="
      .
      Exception in thread "main" java.lang.NoClassDefFoundError: javax/jws/soap/SOAPBinding$ParameterStyle
       at org.jboss.ws.tools.helpers.ToolsHelper.handleJavaToWSDLGeneration(ToolsHelper.java:106)
       at org.jboss.ws.tools.WSTools.process(WSTools.java:133)
       at org.jboss.ws.tools.WSTools.generate(WSTools.java:69)
       at org.jboss.ws.tools.WSTools.generate(WSTools.java:119)
       at org.jboss.ws.tools.WSTools.main(WSTools.java:58)
      
      


      I looked in my libraries and I have the class "javax/jws/soap/SOAPBinding", so I don't understand my problem

      Have anybody ever had this problem and solved it?

      Thank you for your help