5 Replies Latest reply on Apr 16, 2007 1:25 PM by Romeu Figueira

    Generated WSDL has default port 8080 even if server runs on

    Mihai Anescu Newbie

      I'm trying to run the trailblazer from the JBoss ESB, on JBossAS 4.0.5. (the one shipped with ESB 4.0) I have changed the port on the server to 8090, instead of the default one.
      And I have stumbled over a bug related to the WS:
      I have changed everywhere in the code & config the port from 8080 to 8090, but when i deploy to JBoss i get this message:

      2007-04-11 16:16:32,325 INFO [org.jboss.ws.server.ServiceEndpointManager] WebService started: http://ts541:8080/trailblazer/LoanBrokerWS


      Here is a snapshot from the debug section (you can see that every other message reffers to port localhost:8090):
      2007-04-11 16:16:31,309 DEBUG [org.jboss.ws.metadata.wsdl.WSDLDefinitionsFactory] parse: file:/D:/Work/jboss-4.0.5/server/default/tmp/jbossws/LoanBrokerWSService64691.wsdl
      2007-04-11 16:16:31,622 DEBUG [org.jboss.ws.tools.JavaToXSD] load schema: http://localhost:8090/trailblazer=file:/D:/Work/jboss-4.0.5/server/default/tmp/jbossws/JBossWS_localhost_8090_trailblazer64692.xsd
      2007-04-11 16:16:31,622 DEBUG [org.jboss.ws.utils.JBossWSEntityResolver] resolveEntity: [pub=http://schemas.xmlsoap.org/soap/encoding/,sysid=null]
      2007-04-11 16:16:31,669 DEBUG [org.jboss.ws.metadata.wsdl.WSDLInterface] new WSDLInterface
      2007-04-11 16:16:31,669 DEBUG [org.jboss.ws.metadata.wsdl.WSDLInterface] setName: LoanBrokerWS
      2007-04-11 16:16:31,669 DEBUG [org.jboss.ws.metadata.wsdl.WSDLInterface] setQName: {http://localhost:8090/trailblazer}LoanBrokerWS
      2007-04-11 16:16:31,669 DEBUG [org.jboss.ws.metadata.wsdl.WSDLBinding] new WSDLBinding
      2007-04-11 16:16:31,669 DEBUG [org.jboss.ws.metadata.wsdl.WSDLBinding] setQName: {http://localhost:8090/trailblazer}LoanBrokerWSBinding
      2007-04-11 16:16:31,669 DEBUG [org.jboss.ws.metadata.wsdl.WSDLBinding] setName: LoanBrokerWSBinding
      2007-04-11 16:16:31,669 DEBUG [org.jboss.ws.metadata.wsdl.WSDLBinding] setInterfaceName: LoanBrokerWSBinding
      2007-04-11 16:16:31,684 DEBUG [org.jboss.ws.deployment.AbstractMetaDataBuilder] Replace service endpoint address 'REPLACE_WITH_ACTUAL_URL' with 'http://ts541:8080/trailblazer/LoanBrokerWS'


      If you haven't fixed this issue maybe you can investigate the problem?