0 Replies Latest reply on May 23, 2007 10:09 AM by Guillermo Turk

    Port 8080 and Web Services

    Guillermo Turk Newbie

      I can not use port 8080, so I switched to 8082. Everything works fine, but when deploying web services I get this:
      22:05:31,812 INFO [ServiceEndpointManager] WebService started: http://PVGT:8080/pharos

      My web client can access the wsdl but when I try to load the service implmentation class using ServiceFactory, it fails:
      Exception in thread "main" java.lang.NullPointerException
      at java.lang.System.arraycopy(Native Method)
      at org.apache.xerces.impl.xs.XSModelImpl.getAnnotations(Unknown Source)
      at org.jboss.ws.metadata.wsdl.xmlschema.WSSchemaUtils.copyXSModel(WSSchemaUtils.java:737)
      at org.jboss.ws.tools.JavaToXSD.parseSchema(JavaToXSD.java:180)
      at org.jboss.ws.metadata.wsdl.WSDL11Reader.processTypes(WSDL11Reader.java:227)
      at org.jboss.ws.metadata.wsdl.WSDL11Reader.processDefinition(WSDL11Reader.java:118)
      at org.jboss.ws.metadata.wsdl.WSDLDefinitionsFactory.parse(WSDLDefinitionsFactory.java:145)
      at org.jboss.ws.metadata.ServiceMetaData.getWsdlDefinitions(ServiceMetaData.java:273)
      at org.jboss.ws.deployment.JSR109ClientMetaDataBuilder.buildMetaData(JSR109ClientMetaDataBuilder.java:110)
      at org.jboss.ws.deployment.JSR109ClientMetaDataBuilder.buildMetaData(JSR109ClientMetaDataBuilder.java:82)
      at org.jboss.ws.jaxrpc.ServiceImpl.(ServiceImpl.java:96)
      at org.jboss.ws.jaxrpc.ServiceFactoryImpl.createService(ServiceFactoryImpl.java:157)
      at org.jboss.ws.jaxrpc.ServiceFactoryImpl.createService(ServiceFactoryImpl.java:128)
      at PharosWebTest.main(PharosWebTest.java:29)