1 Reply Latest reply on Jun 5, 2007 8:45 AM by Heiko Braun

    MIssing wsdl4j.jar in scripts

    Peter Johnson Master

      When I run the wsrunclient or wsprovide scripts (possibly also with wsconsume, but I am not sure), I get the following exception (if I use the --show-traces option to see what the error was):

      Generating WSDL:
      SalesTaxService.wsdl
      Error: Could not generate. (use --show-traces to see full traces)
      java.lang.NoClassDefFoundError: javax/wsdl/WSDLException
       at org.jboss.ws.tools.wsdl.WSDLWriter.write(WSDLWriter.java:89)
       at org.jboss.ws.metadata.builder.jaxws.JAXWSWebServiceMetaDataBuilder.pr
      ocessOrGenerateWSDL(JAXWSWebServiceMetaDataBuilder.java:292)
       at org.jboss.ws.metadata.builder.jaxws.JAXWSWebServiceMetaDataBuilder.bu
      ildWebServiceMetaData(JAXWSWebServiceMetaDataBuilder.java:131)
       at org.jboss.ws.tools.jaxws.impl.WSContractProviderImpl.provide(WSContra
      ctProviderImpl.java:118)
       at org.jboss.ws.tools.jaxws.impl.WSContractProviderImpl.provide(WSContra
      ctProviderImpl.java:134)
       at org.jboss.ws.tools.jaxws.command.wsprovide.generate(wsprovide.java:16
      7)
       at org.jboss.ws.tools.jaxws.command.wsprovide.main(wsprovide.java:76)


      Adding the client/wsdl4j.jar file to the claspsath constructed in the script solves this problem. What bugs me about this is how these scripts that deal with WSDLs can even run without the WSDL JAR file being included? Is anyone else seeing this error?

      I am seeing this in JBoss AS, both 5.0 beta2 and 4.2.