0 Replies Latest reply on Jun 17, 2007 11:53 PM by Andrew Voumard

    Can I use JWSDP 1.6 tools and runtime with JBoss 4.0.5 GA ?

    Andrew Voumard Newbie

      Hi,

      I am currently using JBoss AS 4.0.3SP1 and use (as a client), web services, whose WSDLs are compiled via wscompile in JWSDP 1.6. That works fine. Those WSDLs I use are supplied by a 3rd party, over whom I have no control, and who use the RPC encoded style extensively. I previously tried to use WSTools to compile the WSDLs, but had problems at runtime due to insufficient support for the RPC encoded style in the new JBoss WS SOAP stack.

      I need to move to 4.0.5 GA for a range of other reasons, and this is currently the stumbling block.

      It there any way I can retrofit the Sun JWSDP runtimes into JBoss 4.0.5 GA ? If so, are there any steps posted for this retrofit, or can anyone guide me in what I would need to do ?

      Thanks
      Andrew