3 Replies Latest reply on Apr 14, 2010 10:19 PM by Viacheslav Garmash

    ClassnotFoundError while trying to use wsrunclient

    Raju Koganty Newbie

      I am trying to run a WebService client generated using wsconsume from JBoss 4.0.5 running on JDK 1.6 using wsrunclient and am running into this error. I do have jaxb-impl.jar in the classpath. How do I ger arounf this issue.

      Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/xml/bind/api/
      TypeReference
      at com.sun.xml.ws.model.RuntimeModeler.processDocWrappedMethod(RuntimeMo
      deler.java:571)
      at com.sun.xml.ws.model.RuntimeModeler.processMethod(RuntimeModeler.java
      :492)
      at com.sun.xml.ws.model.RuntimeModeler.processClass(RuntimeModeler.java:
      334)
      at com.sun.xml.ws.model.RuntimeModeler.buildRuntimeModel(RuntimeModeler.
      java:220)
      at com.sun.xml.ws.client.WSServiceDelegate.addSEI(WSServiceDelegate.java
      :588)
      at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.jav
      a:291)
      at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.jav
      a:274)
      at com.sun.xml.ws.client.WSServiceDelegate.getPort(WSServiceDelegate.jav
      a:267)
      at javax.xml.ws.Service.getPort(Service.java:92)
      at com.extremenetworks.epicenter.client.webservice.ClientManagerBeanServ
      ice.getClientManagerBeanPort(ClientManagerBeanService.java:51)
      at com.extremenetworks.epicenter.client.webservice.Test.main(Test.java:2
      2)