2 Replies Latest reply on Aug 7, 2007 6:48 AM by Matt Law

    Deployment exception with JbossWs 2.0.0 - Cannot find servic

    Matt Law Newbie

      I am deploying a set of EJB3 classes to JBoss 4.0.5 which has EJB3 rc9 & JBossWS 2.0.0 installed. Previously the ejbs have been deployed to jboss 4.0.4 with ejb3 rc9 & jbossws 1.2 with no errors. Now when I start jboss I get the following error

      11:21:49,965 ERROR [MainDeployer] Could not start deployment: file:/C:/Development/jboss/jboss-4.0.5.GA.TMP/server/default/deploy/GermanPatientHistoryEJB.jar
      javax.xml.ws.WebServiceException: Cannot find service endpoint target: jboss.j2ee:name=AddressServiceBean,service=EJB3,jar=GermanPatientHistoryEJB.jar
       at org.jboss.wsf.container.jboss40.InvocationHandlerEJB3.start(InvocationHandlerEJB3.java:70)
       at org.jboss.wsf.spi.deployment.BasicLifecycleHandler.start(BasicLifecycleHandler.java:57)
       at org.jboss.wsf.stack.jbws.LifecycleHandlerImpl.start(LifecycleHandlerImpl.java:40)
       at org.jboss.wsf.spi.deployment.EndpointLifecycleDeployer.start(EndpointLifecycleDeployer.java:49)
       at org.jboss.wsf.spi.deployment.BasicDeployerManager.deploy(BasicDeployerManager.java:81)
       at org.jboss.wsf.container.jboss42.MainDeployerHook.deploy(MainDeployerHook.java:46)
       at org.jboss.wsf.container.jboss42.DeployerInterceptor.start(DeployerInterceptor.java:90)
       at org.jboss.deployment.SubDeployerInterceptorSupport$XMBeanInterceptor.start(SubDeployerInterceptorSupport.java:188)
       at org.jboss.deployment.SubDeployerInterceptor.invoke(SubDeployerInterceptor.java:95)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
       at $Proxy31.start(Unknown Source)
      


      This is despite the fact that I can see the WSDL has been deployed and the endpoint registered -

      11:21:49,903 INFO [BasicEndpointRegistry] register: jboss.ws:context=GermanPatientHistoryEJB,endpoint=AddressServiceBean
      


      I can even view the WSDL through the browser once JBoss completes startup. However, any attempt to invoke them fails.

      I have not changed any annotations in the beans as it all looks to be the same as per the User Guide. I do not understand where the deployer is looking for the endpoint, or what might cause this problem. Any help, suggestions would be great.

      Matt.

        • 1. Re: Deployment exception with JbossWs 2.0.0 - Cannot find se
          Thomas Diesler Master

          This is the code that is failing

           public void init(Endpoint ep)
           {
           String ejbName = ep.getShortName();
           ArchiveDeployment dep = (ArchiveDeployment)ep.getService().getDeployment();
           String nameStr = "jboss.j2ee:name=" + ejbName + ",service=EJB3,jar=" + dep.getSimpleName();
           if (dep.getParent() != null)
           {
           nameStr += ",ear=" + dep.getParent().getSimpleName();
           }
          
           objectName = ObjectNameFactory.create(nameStr.toString());
          
           Dispatcher dispatcher = Dispatcher.singleton;
           if (dispatcher.getRegistered(objectName.getCanonicalName()) == null)
           throw new WebServiceException("Cannot find service endpoint target: " + objectName);
           }
          


          please have a look at the JMX console and tell us the JMX name for your SLSB

          • 2. Re: Deployment exception with JbossWs 2.0.0 - Cannot find se
            Matt Law Newbie

            Thomas, my apologies. If I'd checked more carefully the root cause was a missing datasource, but that error was 2 lines in among 100s. Once that was configured jboss starts just fine.