2 Replies Latest reply on Aug 23, 2007 9:04 AM by Thomas Diesler

    Server startup hangs when injecting @WebServiceRef into an M

    Kevin Pauli Newbie

      Has anybody else observed this behavior? This is with JBoss 4.2.0.GA which uses jbossws-1.2.1.GA.

      I have a web service, like the following:

      Web service:

      package kp;
      
      import javax.ejb.Stateless;
      import javax.jws.WebMethod;
      import javax.jws.WebParam;
      import javax.jws.WebService;
      
      import org.jboss.ws.annotation.WebContext;
      
      @Stateless
      @WebService
      @WebContext(contextRoot="/kp")
      public class HelloWebService
      {
       @WebMethod
       public void hello(@WebParam(name = "name") String name)
       {
       System.out.println("web service invoked! hello, " + name);
       }
      }
      


      I wanted to test it by poking at it and sending it data from the JMX console. So I wrote an MBean to send it data:

      MBean Interface:
      package kp;
      
      import org.jboss.annotation.ejb.Management;
      
      @Management
      public interface AdhocServicesManagement
      {
       void invokeWS(String name);
      }
      
      


      MBean Implementation:
      package kp;
      
      import javax.xml.ws.WebServiceRef;
      
      import org.jboss.annotation.ejb.Service;
      
      @Service
      public class AdhocServicesBean implements AdhocServicesManagement
      {
       @WebServiceRef(wsdlLocation="http://127.0.0.1:8080/kp/HelloWebService?wsdl")
       SearchResultHandlerBean searchResultHandlerBean;
      
       public void invokeWS(String name)
       {
       searchResultHandlerBean.handleSearchResult(name);
       }
      }
      



      But the server seems to hang on startup, with no useful info logged. Here is the last part of the log:

      10:09:07,109 INFO [NamingHelper] JNDI InitialContext properties:{java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory, java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces}
      10:09:07,109 INFO [UpdateTimestampsCache] starting update timestamps cache at region: kpauli-app_ear,kpauli-app_jar,kpauli.org.hibernate.cache.UpdateTimestampsCache
      10:09:07,125 INFO [StandardQueryCache] starting query cache at region: kpauli-app_ear,kpauli-app_jar,kpauli.org.hibernate.cache.StandardQueryCache
      10:09:07,218 INFO [JmxKernelAbstraction] creating wrapper delegate for: org.jboss.ejb3.service.ServiceContainer
      10:09:07,218 INFO [JmxKernelAbstraction] installing MBean: jboss.j2ee:ear=kpauli-app.ear,jar=kpauli-app.jar,name=AdhocServicesBean,service=EJB3 with dependencies:
      10:09:07,375 INFO [ServiceRefHandlerJAXWS] setupServiceRef [jndi=/env/kp.AdhocServicesBean/searchResultHandlerBean,target=kp.SearchResultHandlerBean]
      10:09:07,421 INFO [EJBContainer] STARTED EJB: kp.AdhocServicesBean ejbName: AdhocServicesBean
      


      And there it sits... it never fully initializes.