2 Replies Latest reply on Sep 20, 2007 8:55 AM by Cris

    IllegalStateException: Cannot load SecurityAdaptor while run

    Cris Newbie

      Hello all,

      I am trying to run the SwaRef test sample from JBossWS 2.0 (working under JBoss 4.0.5).

      After building the tests, I execute

      ant -Dtest=jaxws/samples/swaref
      and I get this exception:

      java.lang.IllegalStateException: Cannot load SecurityAdaptor
      at org.jboss.wsf.spi.invocation.SecurityAdaptorFactory.getSecurityAdaptor(SecurityAdaptorFactory.java:40)
       at org.jboss.wsf.spi.test.TestDeployerJBoss.invokeMainDeployer(TestDeployerJBoss.java:81)
       at org.jboss.wsf.spi.test.TestDeployerJBoss.deploy(TestDeployerJBoss.java:68)
       at org.jboss.wsf.spi.test.JBossWSTestHelper.deploy(JBossWSTestHelper.java:58)
       at org.jboss.wsf.spi.test.JBossWSTestSetup.setUp(JBossWSTestSetup.java:94)
       at junit.extensions.TestSetup$1.protect(TestSetup.java:22)
       at junit.framework.TestResult.runProtected(TestResult.java:128)
       at junit.extensions.TestSetup.run(TestSetup.java:27)
       at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:421)
       at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:912)
       at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:766)
      


      Same exception is thrown for every other test sample in the suite.
      Can someone please offer some insight as to why this might be happening?

      Thank you!
      --Chris.