10 Replies Latest reply on Dec 1, 2010 9:42 AM by Igor JStarter

    ClassNotFoundException JBossWSProviderFactoryImpl with JBoss

    Gerald Quintana Newbie

      I get an exception when I run WSProvide:

      $ wsprovide.sh -k -w -c classes -o classes -r jbossws -s jbossws com.mycompany.myapp.ws.MyWebService
      [: 71: /opt/java/jboss-4.2.2.GA/client/jbossws-client.jar: unexpected operator
      JBossWS-SunRI stack deployed
      Exception in thread "main" java.lang.IllegalStateException: Failed to load: org.jboss.ws.tools.jaxws.impl.JBossWSProviderFactoryImpl
       at org.jboss.wsf.spi.util.ServiceLoader.loadDefault(ServiceLoader.java:205)
       at org.jboss.wsf.spi.util.ServiceLoader.loadFromSystemProperty(ServiceLoader.java:138)
       at org.jboss.wsf.spi.util.ServiceLoader.loadService(ServiceLoader.java:68)
       at org.jboss.wsf.spi.tools.WSContractProvider.newInstance(WSContractProvider.java:65)
       at org.jboss.wsf.spi.tools.cmd.WSProvide.generate(WSProvide.java:170)
       at org.jboss.wsf.spi.tools.cmd.WSProvide.main(WSProvide.java:77)
      Caused by: java.lang.ClassNotFoundException: org.jboss.ws.tools.jaxws.impl.JBossWSProviderFactoryImpl
       at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
       at java.security.AccessController.doPrivileged(Native Method)
       at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
       at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
       at org.jboss.wsf.spi.util.ServiceLoader.loadDefault(ServiceLoader.java:200)
       ... 5 more
      

      I am using Ubuntu 7.10, Sun Java 1.5 and standard JBoss 4.2.2.

      What's wrong?