2 Replies Latest reply on Jan 4, 2008 4:47 AM by Jarda Novak

    Clients stopped to work after upgrade from jboss 4.0.5 to 4.

    Jarda Novak Newbie

      Hi all,

      I developed some webservices on jboss 4.0.5, just using annotations like @WebService and @WebMethod. I builded the clients based on axis 1.4. Everything is working fine.

      But now I need to upgrade to jboss 4.2.2, because of new JSF. Unfortunately I found that old webservice clients are no longer working with new version, but I cannot rebuild the clients.

      I tried to set settings from old wsdl:

      @WebService(wsdlLocation = "WebServiceBean.wsdl", targetNamespace = "http://webservice.ejb.company.com/jaws")
      This helped me to avoid the exception, but still my input parameters are null, instead of any value.

      Here is part of my incoming request, which is not correctly parsed:
      <SOAP-ENV:Envelope xmlns:SOAP-ENV='http://schemas.xmlsoap.org/soap/envelope/' xmlns:xsd='http://www.w3.org/2001/XMLSchema' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'>
       <SOAP-ENV:Body>
       <ns1:activate xmlns:ns1='http://webservice.ejb.company.com/jaws'>
       <ns1:Param1>123</ns1:Param1>
      


      Thank you for your help.