0 Replies Latest reply on Feb 19, 2008 7:53 PM by Jeremy Friesen

    Webservice appears to deploy, but doesn't...  Why not?

    Jeremy Friesen Newbie

      I have a webservice that appears to deploy, with jboss saying the following:

      16:20:00,006 INFO [EARDeployer] Init J2EE application: file:/C:/jboss-4.2.1.GA/server/default/deploy/ProjectName_EAR-0.0.1.ear
      16:20:00,787 INFO [JmxKernelAbstraction] creating wrapper delegate for: org.jboss.ejb3.stateless.StatelessContainer
      16:20:00,787 INFO [JmxKernelAbstraction] installing MBean: jboss.j2ee:ear=ProjectName_EAR-0.0.1.ear,jar=ProjectName-1.0-SNAPSHOT.jar,name=Import,service=EJB3 with dependencies:
      16:20:00,837 INFO [EJBContainer] STARTED EJB: com.owfg.ProjectName.webservice.Import ejbName: Import
      16:20:00,857 INFO [EJB3Deployer] Deployed: file:/C:/jboss-4.2.1.GA/server/default/tmp/deploy/tmp24683ProjectName_EAR-0.0.1.ear-co
      ntents/lib/ProjectName-1.0-SNAPSHOT.jar
      16:20:00,877 INFO [EARDeployer] Started J2EE application: file:/C:/jboss-4.2.1.GA/server/default/deploy/ProjectName_EAR-0.0.1.ear


      However, comparing it to another webservice that was deployed, it's missing a few pieces (italicized):

      16:19:45,657 INFO [EARDeployer] Init J2EE application: file:/C:/jboss-4.2.1.GA/server/default/deploy/Project2_EAR-0.0.1.ear
      16:19:49,362 WARN [MainDeployer] Found non-jar deployer for SNMPRelay-1.0-SNAPSHOT.jar: MBeanProxyExt[jboss.ejb3:service=EJB3Deployer]
      16:19:57,693 INFO [TomcatDeployer] deploy, ctxPath=/Project2Service, warUrl=.../tmp/deploy/Project2_EAR-0.0.1.ear-Project2-1.0-SNAPSHOT.jar-ws24682.w
      ar/

      16:19:58,204 INFO [JmxKernelAbstraction] creating wrapper delegate for: org.jboss.ejb3.stateless.StatelessContainer
      16:19:58,224 INFO [JmxKernelAbstraction] installing MBean: jboss.j2ee:ear=Project2_EAR-0.0.1.ear,jar=Project2-1.0-SNAPSHOT.jar,name=Project2,service=
      EJB3 with dependencies:
      16:19:58,574 INFO [EJBContainer] STARTED EJB: com.owfg.Project2.webservice.Project2ejbName: Project2
      16:19:58,614 INFO [EJB3Deployer] Deployed: file:/C:/jboss-4.2.1.GA/server/default/tmp/deploy/tmp24679Project2_EAR-0.0.1.ear-contents/lib/Project2-1.0
      -SNAPSHOT.jar
      16:19:58,915 INFO [WSDLFilePublisher] WSDL published to: file:/C:/jboss-4.2.1.GA/server/default/data/wsdl/Project2_EAR-0.0.1.ear/Project2-1.0-SNAPSHO
      T.jar/Project2Service24680.wsdl
      16:19:59,556 INFO [ServiceEndpointManager] WebService started: http://localhost:8080/Project2Service/Project2

      16:19:59,576 INFO [EARDeployer] Started J2EE application: file:/C:/jboss-4.2.1.GA/server/default/deploy/Project2_EAR-0.0.1.ear


      Both webservices are annotated as @WebService and @Stateless, but the one that isn't deploying properly is implementing ImportRemote and ImportLocal classes, which are just simple interfaces with @Remote or @Local respectively. For some reason recently jboss started complaining that there were no remote or local interfaces, so I added them. It's strange that it wasn't complaining in the past, and still doesn't complain about Project2 not having any.

      Any ideas where I can find clues to figure out why it isn't deploying properly (or, if it is the base issue, why jboss suddenly starting asking for interfaces)?

      Thanks so much.