0 Replies Latest reply on May 9, 2008 6:49 PM by Hattori Hanzo

    Basic Web Service with client

    Hattori Hanzo Newbie

      Hi Guys look i have this problem, im trying to run in my JBOSS 4.0.2 Application Server one Simple Web Service Project, i already build my service.xml archive like this...

      <?xml version="1.0" encoding="UTF-8"?>
      <web-app xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="2.4" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">

      <servlet-name>XFireServlet</servlet-name>
      <servlet-class>org.codehaus.xfire.transport.http.XFireConfigurableServlet</servlet-class>
      <load-on-startup>0</load-on-startup>

      <servlet-mapping>
      <servlet-name>XFireServlet</servlet-name>
      <url-pattern>/services/*</url-pattern>
      </servlet-mapping>
      <welcome-file-list>
      <welcome-file>index.jsp</welcome-file>
      </welcome-file-list>
      </web-app>

      And i create my clase and the interface of this class this way...

      The interface Class

      //Generated by MyEclipse

      public interface ITest_WService {

      public String example(String message);

      }

      The Class


      //Generated by MyEclipse

      public class Test_WServiceImpl implements ITest_WService {

      public String example(String message) {
      return message;
      }

      }


      And i already build a new WSDL archive...

      <?xml version="1.0" encoding="UTF-8"?>
      <wsdl:definitions xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:tns="http://www.example.org/testws/" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" name="testws" targetNamespace="http://www.example.org/testws/">
      <wsdl:types>
      <xsd:schema targetNamespace="http://www.example.org/testws/">
      <xsd:element name="NewOperation">
      <xsd:complexType>
      <xsd:sequence>
      <xsd:element name="in" type="xsd:string"/>
      </xsd:sequence>
      </xsd:complexType>
      </xsd:element>
      <xsd:element name="NewOperationResponse">
      <xsd:complexType>
      <xsd:sequence>
      <xsd:element name="out" type="xsd:string"/>
      </xsd:sequence>
      </xsd:complexType>
      </xsd:element>
      <xsd:element name="DatoEntrada" type="xsd:string"></xsd:element>
      <xsd:element name="DatoSalida" type="xsd:string"></xsd:element>
      </xsd:schema>
      </wsdl:types>
      <wsdl:message name="NewOperationRequest">
      <wsdl:part element="tns:DatoEntrada" name="parameters"/>
      </wsdl:message>
      <wsdl:message name="NewOperationResponse">
      <wsdl:part element="tns:DatoSalida" name="parameters"/>
      </wsdl:message>
      <wsdl:portType name="testws">
      <wsdl:operation name="NewOperation">
      <wsdl:input message="tns:NewOperationRequest"/>
      <wsdl:output message="tns:NewOperationResponse"/>
      </wsdl:operation>
      </wsdl:portType>
      <wsdl:binding name="testwsSOAP" type="tns:testws">
      <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
      <wsdl:operation name="NewOperation">
      <soap:operation soapAction="http://www.example.org/testws/NewOperation"/>
      <wsdl:input>
      <soap:body use="literal"/>
      </wsdl:input>
      <wsdl:output>
      <soap:body use="literal"/>
      </wsdl:output>
      </wsdl:operation>
      </wsdl:binding>
      <wsdl:service name="testws">
      <wsdl:port binding="tns:testwsSOAP" name="testwsSOAP">
      <soap:address location="http://www.example.org/"/>
      </wsdl:port>
      </wsdl:service>
      </wsdl:definitions>


      so.. now when i open my Web Service Explorer to test my wsdl archive, i send the string and the request of that petition is this...

      The SOAP response failed schema validation. Please switch to the source view for the SOAP response in XML format.

      Can some one help me pls? im using JDK 1.5.0_15 version and my Application Server is JBOSS 4.0.2

      maybe i think is some problem with the versions, but maybe was the code or the XFire :( i dont know can somebody help me pls?