2 Replies Latest reply on Apr 21, 2008 11:30 AM by Anthony Galati

    Having trouble with RichFaces and OC4J 10.1.3.1

    Anthony Galati Newbie

      I have been trying to get RichFaces to work and keep getting different errors within Eclipse.

      Here is what I have done so far. In my Ear Project, I have the orion-application.xml with the following


      <?xml version='1.0' encoding='UTF-8'?>
      <orion-application xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://xmlns.oracle.com/oracleas/schema/orion-application-10_0.xsd" >
       <imported-shared-libraries>
       <remove-inherited name="oracle.xml" />
       <import-shared-library name="xerces.xml" max-version="2.9.1"/>
      <!--
       <remove-inherited name="oracle.toplink" />
       <remove-inherited name="oracle.persistence" />
       <import-shared-library name="jaxp-jwsdp" max-version="1.5"/>
      -->
       </imported-shared-libraries>
      </orion-application>
      


      I have the following library's in my /WEBINF/lib
      commons-beanutils.jar
      commons-codec-1.3.jar
      commons-collections.jar
      commons-digester.jar
      el-api.jar
      el-ri.jar
      jsf-api.jar
      jsf-facelets.jar
      jsf-impl.jar
      jstl.jar
      richfaces-api-3.1.3.GA.jar
      richfaces-impl-3.1.3.GA.jar
      richfaces-ui-3.1.3.GA.jar

      I am getting the following error publishing through eclipse to OC4J 10.1.3.1

      08/04/18 10:44:54 WARNING: DeployerRunnable.run NoClassDefFoundErrororacle.oc4j.admin.internal.DeployerException: NoClassDefFoundError
      at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.java:134)
      at oracle.oc4j.admin.jmx.server.mbeans.deploy.OC4JDeployerRunnable.doRun(OC4JDeployerRunnable.java:52)
      at oracle.oc4j.admin.jmx.server.mbeans.deploy.DeployerRunnable.run(DeployerRunnable.java:81)
      at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:298)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: java.lang.NoClassDefFoundError
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:242)
      at com.evermind.server.http.deployment.WARAnnotationParser.getFilterClasses(WARAnnotationParser.java:171)
      at com.evermind.server.http.deployment.WARAnnotationParser.parseAnnotations(WARAnnotationParser.java:95)
      at com.evermind.server.http.HttpApplication.parseMetaData(HttpApplication.java:8575)
      at com.evermind.server.http.HttpApplication.initDynamic(HttpApplication.java:1113)
      at com.evermind.server.http.HttpApplication.(HttpApplication.java:738)
      at com.evermind.server.ApplicationStateRunning.getHttpApplication(ApplicationStateRunning.java:414)
      at com.evermind.server.Application.getHttpApplication(Application.java:571)
      at com.evermind.server.http.HttpSite$HttpApplicationRunTimeReference.createHttpApplicationFromReference(HttpSite.java:1990)
      at com.evermind.server.http.HttpSite$HttpApplicationRunTimeReference.(HttpSite.java:1909)
      at com.evermind.server.http.HttpSite.addHttpApplication(HttpSite.java:1606)
      at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:238)
      at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:99)
      at oracle.oc4j.admin.internal.ApplicationDeployer.bindWebApp(ApplicationDeployer.java:547)
      at oracle.oc4j.admin.internal.ApplicationDeployer.doDeploy(ApplicationDeployer.java:202)
      at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.java:93)
      ... 4 more

      I have the richfaces*.jars referenced in the OC4J instance's class path, because if I don't then I get an error saying it couldn't find the tld lib. I can recreate if it is needed. But that is all I have in the class path of the OC4J instance.

      Any ideas


        • 1. Re: Having trouble with RichFaces and OC4J 10.1.3.1
          Anthony Galati Newbie

          Now I am getting this

          2008-04-21 09:02:10.000 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.CalendarTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.000 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.ListShuttleTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.015 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.InputNumberSliderTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.015 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.HtmlToolTipTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.015 NOTIFICATION J2EE JSP0046 Unable to load class org.ajax4jsf.taglib.html.jsp.ActionParam while scanning for annotated JSP tags.
          2008-04-21 09:02:10.015 NOTIFICATION J2EE JSP0046 Unable to load class org.ajax4jsf.taglib.html.jsp.AjaxPushTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.015 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.PanelMenuGroupTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.031 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.DataGridTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.031 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.DropSupportTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.031 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.SpacerTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.031 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.RichMessagesTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.046 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.TogglePanelTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.046 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.GmapTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.046 NOTIFICATION J2EE JSP0046 Unable to load class org.ajax4jsf.taglib.html.jsp.MediaOutputTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.046 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.TreeNodesAdaptorTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.046 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.ContextMenuTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.062 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.TreeTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.062 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.ToggleControlTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.062 NOTIFICATION J2EE JSP0046 Unable to load class org.ajax4jsf.taglib.html.jsp.LogTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.078 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.OrderingListTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.078 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.taglib.ModalPanelTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.078 NOTIFICATION J2EE JSP0046 Unable to load class org.richfaces.ui.taglib.InsertTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.078 NOTIFICATION J2EE JSP0046 Unable to load class org.ajax4jsf.taglib.html.jsp.AjaxPollTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.093 NOTIFICATION J2EE JSP0046 Unable to load class org.ajax4jsf.taglib.html.jsp.FormTag while scanning for annotated JSP tags.
          2008-04-21 09:02:10.093 NOTIFICATION J2EE JSP0046 Unable to load class org.ajax4jsf.taglib.html.jsp.AjaxPage while scanning for annotated JSP tags.


          I have the .jar files located in my WEBINF/lib directory. Whenever I deploy this, it doesn't work and I get the above text.

          • 2. Re: Having trouble with RichFaces and OC4J 10.1.3.1
            Anthony Galati Newbie

            I finally think I have figured it out.

            I was writing my pages in .jsp instead of .xhtml.

            Even though I could get them to work inside of Tomcat 6.0 I couldn't inside of OC4J 10.1.3.1

            What I think is that OC4J 10.1.3.1 doesn't support the newest version of JSP so it would have a problem compiling it.

            Once I switched the page to .xhtml and changed my web.xml. Everything worked correctly.