1 Reply Latest reply on Aug 25, 2008 10:57 AM by Alessio Soldano

    [UsingAddressing] tag is not added to auto-generated WSDL fo

    Alexandros Karypidis Novice

      Hi,

      I used the @EndpointConfig annotation to add WS-Addressing handlers to my SEI implementation as described in the WS-Addressing tutorial. I noticed however that even though JBoss adds the WS-Addressing handlers to the the endpoint, it does not specify it in the WSDL that gets published for the web service. In fact, the WSDL generated and published is identical whether you enable WS-Addressing or not.

      The WS-Addressing tutorial at http://jbws.dyndns.org/mediawiki/index.php?title=Native_WS-Addressing_Tutorial uses a "manual" approach to make this information available in the contract: It uses the "wsdlLocation" attribute of the @WebService annotation to refer to a pre-constructed WSDL that has an appropriate service definition:

      <service name='AddressingService'>
       <port binding='tns:ServiceIfaceBinding' name='AddressingServicePort'>
       <soap:address location='REPLACE_WITH_ACTUAL_URL'/>
       <!-- - - - - - - - - - - - - - - -->
       <!-- Added extensibility element -->
       <!-- - - - - - - - - - - - - - - -->
       <UsingAddressing xmlns="http://www.w3.org/2006/05/addressing/wsdl"/>
       </port>
       </service>


      I would expect JBoss to add the UsingAddressing tag to the generated WSDL contract to "warn" clients that it is required.

      Is this only possible when using pre-constructed WSDL?