5 Replies Latest reply on Nov 7, 2008 1:12 PM by tonioc

    Jboss 4.2.2 hangs when after deploying a WAR


      I'm using jbossws 3.0.4 in jboss 4.2.2, installation went good, and I
      try my first EchoService as a webapp, all ok.

      After that I added a method that returns a BizClass,

      BizClass getBizClass() {
       return new BizClass();

      The BizClassTree is in an external jar.

      This BizClass is the root of a tree of
      about 500 classes all JAXB annotated, they work pretty well if I
      generate the xml/schema using JAXB just in Java class main method.

      When I deploy the WAR, the context is created, after a while the
      WSDL is generated (I could see it in HTTP: and file:), and jboss continues working (100% of processor) and does not stop.

      If I call the service an exception is thrown telling me:
      Endpoint cannot handle requests in state: CREATED

      In JBossWs/services page, Start Time has a value of null.

      No log is shown (I added DEBUG to org.jboss.ws).

      Any help or ideas will be greatly welcomed

        • 1. Re: Jboss 4.2.2 hangs when after deploying a WAR


          I've now tested with jboss-4.2.3 / jbossws-3.0.4, the same problem.


          • 2. Re: Jboss 4.2.2 hangs when after deploying a WAR

            finally I obtained the log (which full filled my file-system)

            It seems some recursive behavior is the cause of this

            here is the log:

            2008-10-30 18:01:08,213 INFO [org.jboss.wsf.stack.jbws.WSDLFilePublisher] WSDL published to: file:/home/xtra/u/jdesa/mccg/jboss-4.2.2.GA/server/default/data/wsdl/wstest.war/EchoService23289.wsdl
            2008-10-30 18:01:08,394 DEBUG [org.jboss.wsf.framework.deployment.DeploymentAspectManagerImpl] EagerInitializeDeploymentAspect:Start
            2008-10-30 18:01:08,394 DEBUG [org.jboss.ws.metadata.umdm.UnifiedMetaData] Eagerly initialize the meta data model
            2008-10-30 18:01:08,397 DEBUG [org.jboss.ws.metadata.wsdl.xmlschema.JBossXSModel] Registered as anon type: {http://www.mccg.net/xsd/phoenix/base-types/claim.xsd:>claimInvolvedParty>listOfExtraAttr} -> Complex type name='http://www.mccg.net/xsd/phoenix/base-types/basic.xsd,#AnonType_listOfExtraAttribsObject', base type name='anyType', content type='ELEMENT', isAbstract='false', hasTypeId='false', final='0', block='0', particle='("http://www.mccg.net/xsd/phoenix/base-types/basic.xsd":extraAttr{0-UNBOUNDED})', derivedBy='RESTRICTION'.

            There are 20Gb similar to the last line, I was not able to
            find out a pattern that let me understand what is happening
            it seems that the JBossXSModel (not sure what it is) is not capable of managing some kind of recursive references (?) inside an schema.

            I tried a basic example Contact->ListOfAddress and Address->ListOfContact and it worked ok.

            Continue investigating....
            thanks to anybody who bothers reading my-emails

            • 3. Re: Jboss 4.2.2 hangs when after deploying a WAR

              This problem was also reported some time ago in:

              JBossXSModel goes into endless loop

              • 4. Re: Jboss 4.2.2 hangs when after deploying a WAR

                Please file a jira issue for this, if possible with an application reproducing the issue, so that we can work on it.

                • 5. Re: Jboss 4.2.2 hangs when after deploying a WAR

                  Ok I'll do it.

                  I was trying to construct a small example that can show this problem, but until know I was not able.

                  I'll continue working on it.