0 Replies Latest reply on Jan 20, 2009 1:09 AM by pcheng

    soap message fails at JBoss 4.3 eap

    pcheng Newbie

      Hi All,
      We have an existing application that talks to a time clock which uses ksoap to create soap messages. It has been working fine with JBoss 4.0.5 but fails when we deploy the application under JBoss 4.3 eap. Please help to solve it. Here are the details:

      The soap message from the clock is (copied from JBoss server.log):

      <SOAP-ENV:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
      <SOAP-ENV:Body SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
      <getNewSession xmlns="urn:com.tomax.peripheralserver.adapter" id="o0" SOAP-ENC:root="1">
      <user xmlns="" xsi:type="xsd:string">HQ1
      <pass xmlns="" xsi:type="xsd:string">manager1
      <alias xmlns="" xsi:type="xsd:string">GENUS796200

      </SOAP-ENV:Body>
      </SOAP-ENV:Envelope>

      JBoss 4.3 throws this error in server.log:

      2009-01-19 21:33:53,453 ERROR [org.jboss.ws.core.jaxws.SOAPFaultHelperJAXWS] SOAP request exception
      org.jboss.ws.WSException: Content root name does not match element name: {urn:com.tomax.peripheralserver.adapter}user != user
      at org.jboss.ws.core.soap.XMLContent.expandContainerChildren(XMLContent.java:308)
      at org.jboss.ws.core.soap.XMLContent.transitionTo(XMLContent.java:106)
      ....
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      at java.lang.Thread.run(Thread.java:595)


      The generated wsdl file in tmp directory:(sorry the page just does not show the content of wsdl file and I can't figure it out)

      <?xml version="1.0" encoding="UTF-8"?>
      <definitions name='PSAdapterWebServiceImplService' targetNamespace='urn:com.tomax.peripheralserver.adapter' xmlns='http://schemas.xmlsoap.org/wsdl/' xmlns:soap='http://schemas.xmlsoap.org/wsdl/soap/' xmlns:tns='urn:com.tomax.peripheralserver.adapter' xmlns:xsd='http://www.w3.org/2001/XMLSchema'>
      ...

      <soap:binding style='rpc' transport='http://schemas.xmlsoap.org/soap/http'/>

      Thanks a lot.