2 Replies Latest reply on Apr 29, 2009 2:13 AM by Joshua Dev

    WSConsume does not support JAX-WS 2.1 with JBossWS 3.0.5 Nat

    Joshua Dev Newbie

      I upgraded JBoss-WS stack that was in the JBoss AS 4.2.2.GA to JBossWS 3.0.5 Native because the supplied version had issues with deploying WebServices over SSL connectors.

      3.0.5 deploys them fine, but I just noticed that WSConsume stopped working using parameters I used with the AS 4.2.2.GA standard JBossWS stack:

      wsconsume.bat -k -s src -p dummy.package.ws -t 2.1 -o bin --binding=ws-gen\simple.xjb http://127.0.0.1:8080/dummy-context/TestBean?wsdl

      3.0.5 complains that
      Error: WSConsume (native) only supports JAX-WS 2.0

      How is it possible that the earlier version (the default in AS 4.2.2.GA) supported "--target=2.1" for JAX-WS 2.1 and the newer version does not?

        • 1. Re: WSConsume does not support JAX-WS 2.1 with JBossWS 3.0.5
          Alessio Soldano Master

          I'd need to double check what was available in AS 4.2.2, I think the -t 2.1 option was later disabled because the implementation of JAX-WS 2.1 was not complete yet.
          For sure you can use the 2.1 target starting from JBossWS Native 3.1.0.GA as the JAX-WS 2.1 has been completed there.
          Otherwise (if you cant move to AS 4.2.3 which is the oldest target container supported by JBossWS 3.1.0) try with JBossWS-Metro 3.0.5, which already had full JAX-WS 2.1 impl.

          • 2. Re: WSConsume does not support JAX-WS 2.1 with JBossWS 3.0.5
            Joshua Dev Newbie

            Thank you for the answers. I've decided to step back and use JAX-WS 2.0, hopefully integration with external parties won't be a problem.

            "alessio.soldano@jboss.com" wrote:
            I'd need to double check what was available in AS 4.2.2, I think the -t 2.1 option was later disabled because the implementation of JAX-WS 2.1 was not complete yet.

            I am sure I used the "-t 2.1" switch on default install of AS 4.2.2.GA.

            "alessio.soldano@jboss.com" wrote:
            For sure you can use the 2.1 target starting from JBossWS Native 3.1.0.GA as the JAX-WS 2.1 has been completed there.
            Otherwise (if you cant move to AS 4.2.3 which is the oldest target container supported by JBossWS 3.1.0) try with JBossWS-Metro 3.0.5, which already had full JAX-WS 2.1 impl.

            I'll probably have to stay with 4.2.2 now, but I'll take the information about working WS 3.1.0 and JAX-WS 2.1 into accound when I'll be considering AS upgrade.

            The Metro stack was giving me some problems after deployment, I briefly went through the exceptions' stacks but had no time to figure out what exactly went wrong.