1 Reply Latest reply on Jun 26, 2009 6:41 PM by Ben Abernathy

    wsconsume ant task

    K J Newbie

      Hello,

      I am getting the following error when using the wsconsume ant task:

      taskdef class org.jboss.wsf.spi.tools.ant.WSConsumeTask cannot be found
      


      This is my build.xml

      <path id="class.path">
       <pathelement path="C:\Program Files\Java\jdk1.5.0_19\lib\tools.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\streambuffer.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\stax-ex.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\saaj-api.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\saaj-impl.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\jbossws-common.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\jaxws-api.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\jaxws-tools.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\jaxws-rt.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\xmlsec.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\client\*.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\lib\*.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\lib\endorsed\jaxb-api.jar"/>
       <pathelement path="E:\jboss\jboss-5.0.0.GA\lib\endorsed\activation.jar"/>
       </path>
      
       <taskdef name="wsconsume"
       classname="org.jboss.wsf.spi.tools.ant.WSConsumeTask">
       <classpath path="class.path"/>
       </taskdef>
      
      
      
       <target name="generate-from-wsdl">
      
       <wsconsume
       fork="true"
       binding="wsdl/stock.xsd"
       keep="true"
       destdir="generated"
       sourcedestdir="gen-src"
       package="com.sun.samples"
       wsdlLocation="/WEB-INF/wsdl/stockservice.wsdl"
       wsdl="wsdl/stockservice.wsdl">
       </wsconsume>
      
      
       </target>
      


      Can anyone point out..what ma I missing ?

      Thanks