1 Reply Latest reply on Jul 15, 2009 11:58 AM by Alessio Soldano

    JBossAS 5.1.0.GA & 3.1.2.GA & META-INF

    Sefai Tando?an Newbie

      Hi all,

      I have a working war for 4.2.x, containing both a ws client and a server using WSSecurity, when I deploy it on 5.1.0.GA, the serving side worked but client side did not.

      After days of debugging I found out that when application tries to consume some other web-service, standard-jaxws-client-config.xml and jboss-wsse-client.xml which are both located under META-INF are not read, but the client config under server/.../deployers/jbossws.deployer/META-INF/standard-jaxws-client-config.xml is read. So the WSSecurity does not work.

      I moved META-INF under WEB-INF/classes of the war, some wiki I dont remember now was saying resource files must be under WEB-INF/classes for AS 5.x series, this time client worked but applications own WebService did not, it couldn't find standard-jaxws-endpoint-config.xml. So I duplicated META-INF on both directories, now both of them works.

      Also server can find the keystore and truststore under WEB-INF, but the client part can only find them when they are under WEB-INF/classes, so I duplicated them, too.

      I dont know the details of classloading very much, but I suspect this issue is related to it.

      Is this a bug, or known issue of 5.1 which can be avoied with some other setting?

      Thanks in advance...