1 Reply Latest reply on Sep 5, 2009 6:30 PM by Richard Opalka

    running 'ant tests' with 3.2.0.GA fails

    Keith Armstrong Newbie

      I have installed 3.2.0.GA on top of jBoss 5.1.0.GA, and have bound it to address 192.168.174.144, so not localhost.

      However, when I run 'ant tests' as the 2nd part of the install procedure, I get an error in the build:

      [junit] Executing command: /opt/jboss/jboss-5.1.0.GA/bin/wsrunclient.sh junit.textui.TestRunner org.jboss.test.ws.jaxws.samples.webmethod.WebMethodTestCase
      [junit] Process input stream:
      [junit] Process error stream:
      [junit] .E.E.E.E
      [junit] Time: 0.749
      [junit] There were 4 errors:
      [junit] 1) testLegalAccess(org.jboss.test.ws.jaxws.samples.webmethod.WebMethodTestCase)org.jboss.ws.metadata.wsdl.WSDLException: Cannot connect to: http://localhost:8080/jaxws-samples-webmethod/TestService?wsdl

      The build reports:

      org.jboss.test.ws.jaxws.smoke.tools.WSRunClientTestCase FAILED
      org.jboss.test.ws.management.recording.MemoryBufferRecorderTestCase FAILED

      Any help would be appreciated.

      The top of the build looks fine, and I know the variables are set correctly:

      init:
      [echo] integration.target=jboss510

      tests-prepare:
      [echo]
      [echo] -----------------------------------------------
      [echo] jboss.home = /opt/jboss/jboss-5.1.0.GA
      [echo] excludesfile = /opt/jboss/jbossws-native-bin-dist/tests/resources/test-excludes-jboss510.txt
      [echo] java.home = /usr/java/jdk1.6.0_12/jre
      [echo] jboss.bind = 192.168.174.144
      [echo] -----------------------------------------------

      Thanks, Keith