1 Reply Latest reply on Oct 23, 2009 11:07 AM by Sridhar Alapati

    /webservices context root unavialable in jboss 4.2.3 upon re

    Sridhar Alapati Newbie

      I'm running into a problem with jboss webservies and wondering if anyone has a solution for it..

      Our environment:
      Jboss 4.2.3
      Java 1.6
      Ejb 2.1, Ejb3.

      We have an ear application that has two ejb modules in it. One contains ejb2.1 stuff and one contains ejb3 stuff. Both have ejbs and webservices in them. They have two different webservice context roots.
      The ejb2.1 module uses /xxxx-ws as the context root while the ejb3 module uses /webservices as the context root. I run into the problem each time I restart my jboss. For some reason, the /webservices context root is not available when I try to go to the jbossws context to access the wsdls. It gives me HTTP 404 error (the requested resource is not available). The ejb2.1 webservice context is always available though. Only when I delete my ear module from the deploy directory and redeploy the ear, I'm able to see the ejb3 webservices context root and all the wsdls inside that root.
      I'm wondering this is some kind of race condition but not sure.
      Has anyone seen this kind of behavior before? I appreciate any help. Thanks.

        • 1. Re: /webservices context root unavialable in jboss 4.2.3 upo
          Sridhar Alapati Newbie

          Never mind. I found my problem. There's this other ear module that is getting deployed after the ear module I'm having issues with is deployed, and that one has the same /webserives context root for it's webservices. So upon restart, /webservices context is having the last deployed ear module's webservices only. Fixed it by renaming the context to something unique instead.
          I guess the /webservices context is not global across the jboss deployment.