9 Replies Latest reply on May 22, 2008 12:34 AM by TV Ramprasadh

    rich:toolTip is not displayed

    Ruediger xxx Newbie

      Hi,

      i upgraded from richfaces 3.1.3GA to 3.2GA.

      Now i have some problems with tooltips, which worked before the upgrade:

      1) tooltip on h:outputText
      This doesn't work at all anymore. The following code-snippet worked before.

       <h:outputText id="out1" value="test output" >
       <rich:toolTip id="out1_tt" value="tooltip output" showDelay="1000" styleClass="tooltip"/>
       </h:outputText>
      

      I use these a lot in my application, all the labels in my forms have tooltips.

      2) tooltip in rich:dataTable
      This worked before the upgrade and doesn't work anymore.

       <rich:column width="20" style="text-align:center;">
       <f:facet name="header">
       <h:outputText value="header" />
       </f:facet>
       <h:graphicImage id="gih1" value="/images/history_small.gif">
       <rich:toolTip>
       <rich:panel styleClass="tooltip-text">
       <h:outputText value="asdfljasdf"/> </rich:panel>
       </rich:toolTip>
       </h:graphicImage>
      </rich:column>
      


      The datatable tag is as follows:
      <rich:dataTable id="table01" value="#{bean.searchResults}"
       var="elem" width="100%" rows="20"
       rowKeyVar="row" rowClasses="row1, row2" headerClass="cu-tableheader">
      
      


      I tried the tooltip in the datatable with an image and with a command button. Both dont work.
      If i go to the second page via the rich:dataScroller both toolTips are displayed properly.
      Also when i use the new sorting feature on one of the columns the toolTips are displayed properly after sorting the first time.

      Is anybody experiencing the same problems, are these bugs or am i doing something wrong?

      Thanks for your time!