2 Replies Latest reply on Nov 4, 2008 12:24 AM by Richard Opalka

    Trouble with JBoss ESB and Metro-ized Web Services Stack

    Molly Morgan Newbie

      When I run my web services project (using SOAP over http) with a metro-ized JBoss web services stack I get the following run time errors:

      2008-10-29 16:32:34,078 ERROR [org.jboss.wsf.stack.metro.RequestHandlerImpl] Failed to process POST request
      java.lang.UnsupportedOperationException: Not yet supported
      at org.jboss.soa.esb.actions.soap.adapter.SOAPProcessorHttpServletRequest.getScheme(SOAPProcessorHttpServletRequest.java:286)
      at com.sun.xml.ws.transport.http.servlet.ServletConnectionImpl.isSecure(ServletConnectionImpl.java:203)
      at com.sun.xml.ws.transport.http.HttpAdapter.decodePacket(HttpAdapter.java:264)
      at com.sun.xml.ws.transport.http.HttpAdapter.access$500(HttpAdapter.java:93)
      at com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:432)
      at com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:244)
      at com.sun.xml.ws.transport.http.servlet.ServletAdapter.handle(ServletAdapter.java:135)
      at org.jboss.wsf.stack.metro.RequestHandlerImpl.doPost(RequestHandlerImpl.java:225)
      at org.jboss.wsf.stack.metro.RequestHandlerImpl.handleHttpRequest(RequestHandlerImpl.java:82)
      at org.jboss.soa.esb.actions.soap.SOAPProcessor.process(SOAPProcessor.java:185)
      at org.jboss.soa.esb.listeners.message.ActionProcessingPipeline.process(ActionProcessingPipeline.java:316)
      at org.jboss.soa.esb.listeners.message.MessageAwareListener$TransactionalRunner.run(MessageAwareListener.java:530)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)

      Has anyone seen this behavior using SOAP messages and JBoss ESB? Any information would be greatly appreciated - I am running JBoss 4.2.2 and Metro 3.0.3.

      This error does not occur when using JBoss Native Web Services.