1 Reply Latest reply on Jul 23, 2002 10:23 AM by Tobias Frech

    Client throws UnmarshallException after upgrade of JBoss

    Tobias Frech Apprentice

      Q:
      ionel asks:

      When I try to launch a client, it display the following error message :


      javax.naming.CommunicationException. Root exception is java.rmi.UnmarshalException: error unmarshalling return; nested exception is:
      java.lang.ClassNotFoundException: org.jnp.interfaces.MarshalledValuePair
      ...


      mepalmer writes:
      I had been using one of the alpha versions of JBoss 3 and my client programs were able to reference and use my deployed EJBs just fine. Last week I switched over to the final released JBoss 3.0.0. Everything looked like it was running great and fast. But when I tried to run a client program that gets a reference to one of my session beans, I was getting an UnmarshalException. I redeployed all of my EJBs and stuff, but that didn't fix anything. So I took a look at how I was running my client program. I'm running it from within JBuilder and I had a bunch of libraries for the project pointing to the older JBoss-3.0.0alpha version.


        • 1. Re: Client throws UnmarshallException after upgrade of JBoss
          Tobias Frech Apprentice

          A:

          dsundstrom answers:
          My guess is the client and server code are out of sync. Pull the new client jars down to you client deployment and it will ... start working again.

          mepalmer writes:
          I switched the libraries to the correct newer files and ran the client program and it worked great.

          marc fleury explains:
          The client side classes were under great movement, so we apologize for the fact that unmarshalling on old classes will throw exceptions. The classes are stabilized now but we will optimize the writing of it (work underway as we speak) as optimized writers bring about a 30% increase in speed. So you might see more of that in the future.