0 Replies Latest reply on Feb 12, 2004 10:48 AM by dreimer

    JBoss 3.2.3 on jre 1.3.1 fails with AbstractMethodError on s

    dreimer Newbie

      I encountered this issue myself and noticed other postings on this in other forums and mailings lists. The compiled JBoss 3.2.3 ran fine on jre 1.3.1 on RedHat Linux, but failed at startup with an AbstractMethodError when running on the jre 1.3.1 on SCO Unix (1.3.1 is the latest java runtime I can get for SCO OpenServer). This is apparently also a problem on Debian and BSD. The solution is simple. Apparently JBoss 3.2.3 is compiled with the 1.4 sdk which causes a problem on some 1.3.1 jres but not others (?). Just download the JBoss source and compile with the 1.3.1 sdk and everything should work fine. Perhaps JBoss.org could make people aware of this issue on the download page.

      Example posts:
      http://www.jboss.org/index.html?module=bb&op=viewtopic&t=41625
      http://www.jboss.org/index.html?module=bb&op=viewtopic&t=39479