2 Replies Latest reply on Nov 13, 2006 8:14 AM by ivanneto

    Problems displaying results


      After playing with JBoss Profiler for almost a hole day, I still can't see the results in the profiler web application. Following the suggestions I found in the forum didn't solve my problem either.

      What I did:

      1. I compiled the "libjbossInspector.so".
      2. I added it to the LD_LIBRARY_PATH
      3. I copied both jboss-profiler-noAOP.sar and jboss-profiler.war to the JBoss deploy directory.
      4. I edited JBoss "run.conf" and added the string "-XrunjbossInspector:/tmp,memory=false" to the JAVA_OPTS variable. When I start JBoss, it shows:

      "JAVA_OPTS: -Dprogram.name=run.sh -server -Xms128m -Xmx512m -XrunjbossInspector:/tmp,memory=false -Dorg.jboss.resolver.warning=false -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
      Running process 7429
      JBossProfiler: Disabling memory events

      So I guess the installation is OK.

      5. I went to the jmx-console, clicked on the link "Native-profiler" and then on the "Invoke" button of the "activate" operation (the console prints "JBossProfiler: Initializing DataGathering").
      6. I executed a stand-alone application that makes some requests to Web services deployed on JBoss. Looking in the server log, I can see that the Web services are really called.
      7. I clicked on the "Invoke"button of the "stop" MBean operation. The console shows the message "Stopping DataGathering".
      8. I went to the JBoss Profiler web application, clicked on the "Runtime Profiler" link, entered "/tmp" as the directory with runtime capturing, and then choosed the correct process ID (showed on server startup).
      9. Then I got (in the browser) a lot of

      Opening /tmp/serverspy_7169_thread_1163192783096_0_27.log.gz

      but no "processing" or something like that. Just "opening". Then I can see

      Process Finished.... click here

      When I click there, I got (in the browser) a table with only one row, which has the method name:


      On the server console I can see lots of these messages:

      18:41:32,424 ERROR [STDERR] WARNING on JBPCall: Cannot synchronize correctly methods calls
      18:41:32,425 INFO [STDOUT] WARNING on JBPCall: Cannot synchronize correctly methods calls

      Am I doing something wrong? I'm running JBoss Profiler CR4 on JBoss 5.0 (SVN trunk), but I also tested with 4.0.4.GA and got the same problem.

      I've tried just "-XrunjbossInspector:/tmp", and a lot of options combinations. None of them worked.

      Any help would be appreciated.


        • 1. Re: Problems displaying results

          What OS and JDK version are you using?

          I will try to replicate your environment here and see what I got.

          • 2. Re: Problems displaying results

            Hi Clebert.

            Sorry for the delayed answer. I've done some more tests and I think that JBoss Profiler has some problems with Linux/AMD64 environments. I tried the same steps I described in my previous post, but this time I ran JBoss using a 32-bit Sun JVM. Everything went OK.

            The config I used before (no success):
            Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)
            Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_08-b03, mixed mode)
            Linux 2.6.17-2-amd64
            JBoss (MX MicroKernel) [5.0.0.Beta (build: CVSTag=HEAD date=200609140344)]

            The config I used in a successful test:
            Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
            Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode)
            Same kernel, same JBoss version

            I just changed the VM from a 64-bit to a 32-bit version and everything went just fine.

            Best regards,