2 Replies Latest reply: May 19, 2010 4:21 AM by Jesper Pedersen RSS

    Profiler running, no data captured

    Julian Richards Newbie

      Hi folks,

      I'm trying to profile two WAR apps, one Seam and one Spring, with the v2 profiler. The profiler has been installed and is running (I can access the Controller MBean in the web-console), but when I look at the snapshots there's nothing recorded in the reports.

      Installation was almost exactly according to README.txt except that I had to put jboss-profiler.jar in $JBOSS_HOME/server/all/lib to correct a class not found exception on org.jboss.profiler.shared.Command.

      Environment is OSX 10.4; JB 4.2.2.GA; java 1.5.0_13.

      jboss-profiler.properties has the following set for include/exclude:

      includes=edu.*|private,org.alfresco.*|private
      excludes=org.jboss.*


      and I'm running as:

      java -jar jboss-profiler-client.jar startProfiler
      (run through web app in browser)
      java -jar jboss-profiler-client.jar stopProfiler
      java -jar jboss-profiler-client.jar getSnapshot 1 (or 2, or 3...)


      The output directory is created, but the report .txt files are just stubs:

      cat 20080714133618745-20080714133702906/overview.txt
      From: 14 July 2008 13:36:18:745
      To : 14 July 2008 13:37:02:906
      
      Threads:
      ========
      
      Most time:
      ==========
      Count Ms % Method
      
      Hotspots:
      =========
      Count Ms Avg % Method
      
      
      Classes:
      ========



      I've tried changing the includes/excludes values to be more or less precise (anything from just "*" to a fully-qualified class name), but no effect. I can't think what else might be going on to prevent the data capture. Any pointers would be very welcome.