8 Replies Latest reply on Apr 5, 2010 1:00 PM by Jesper Pedersen

    Problem with JBoss Profiler 2 Beta install.

    Vincent Castellano Newbie

      I have installed one of the profiler 2 beta files, the larger of the two, though it's not clear if I need both or not. I believe I have followed the instructions in the README.txt, but starting JBoss fails:


      JBoss Bootstrap Environment

      JBOSS_HOME: /jboss/jboss-4.2.3.GA-src/build/output/jboss-4.2.3.GA

      JAVA: /usr/java/jdk1.5.0_16//bin/java

      JAVA_OPTS: -javaagent:jboss-profiler.jar -Djboss-profiler.properties=jboss-profiler.properties -Dprogram.name=run.sh -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true

      CLASSPATH: /jboss/jboss-4.2.3.GA-src/build/output/jboss-4.2.3.GA/bin/run.jar:/usr/java/jdk1.5.0_16//lib/tools.jar


      Error opening zip file: jboss-profiler.jar
      Error occurred during initialization of VM
      agent library failed to init: instrument

      The bin directory contains:

      asm.jar jboss_init_suse.sh shutdown.jar wsprovide.sh
      classpath.sh probe.bat shutdown.sh wsrunclient.bat
      javassist.jar probe.sh twiddle.bat wsrunclient.sh
      jboss-profiler-plugins.jar run.bat twiddle.jar wstools.bat
      jboss-profiler.jar run.conf twiddle.sh wstools.sh
      jboss-profiler.properties run.jar wsconsume.bat
      jboss_init_hpux.sh run.sh wsconsume.sh
      jboss_init_redhat.sh shutdown.bat wsprovide.bat

      I saw a similar post, so I have already checked the jar files with "jar tf ..." and they all appear to be fine. I also tried adding hte profiler jars to the classpath, but that id not help.

      I tried the example but the class can't be found. I guess you have to do the local build for that to work.

      Is there anything more I can check or do to generate any more information?