0 Replies Latest reply on May 2, 2008 4:30 PM by Joe Sage

    Problems upgrading from RichFaces 3.1.2 to 3.2.0.GA

    Joe Sage Newbie

      Our team developed a b2b application using JSF 1.2_04 PO2 and RichFaces 3.1.2. It is running on a Tomcat server 6.0.14 and is using Apache 2.2.3 as the Web server.

      I'm experiencing problems trying to upgrade the application to RichFaces 3.2.0.GA.
      The problems are JavaScript related not with anything our team wrote but with the RichFaces 3.2.0.GA scripts. These problems only occur when using an IE Browser 7.0.5730.11 (128 bit). The app performs fine with FireFox 2.0.0.13. However, our company only wants to support IE.

      The primary page of our application was created using a4j tags (Ajax support) along with several RichFaces tags. Some of the controls that appear on this page are built dynamically (in the backer) so I’m not sure if this is contributing to our problems. However the application performs fine under RichFaces 3.1.2 and is already in production being used by clients without problems.

      The page layout is very similar to Windows Explorer File Manager. There is a RichFaces menu at the top of the page, on the left side of the page is a RichFaces tree, and the center of the page is RichFaces panel(s). The panels contain form information that changes based on the node the user clicks on in the left tree. This is done by using binding variables associated to rendered tags. The variables are set based on business logic in the backer.
      When we upgrade to RichFaces 3.2.0.GA we encounter JavaScript errors when we click on a node in the Left tree. Using MS Visual studio the error is occurring on Element.extend(element) the error message is '˜Jscript does not support...'€™

      We would like to upgrade our app to 3.2.0 but it appears that it may require a re-write of the page? It seems extreme since it's working under 3.1.2?

      Any thoughts