2 Replies Latest reply on May 9, 2008 8:15 AM by Jeff Guinness

    Hidden cursor in input fields

    Jeff Guinness Newbie

      I'm using Firefox on Windows and showing a modalPanel with input fields when the page loads results in an invisible cursor. Moving the modelPanel a couple of pixels by clicking the title bar and dragging causes the cursor to appear.

      I have tried showing the modalPanel by using

      showWhenRendered="true"
      and by calling
      Richfaces.showModalPanel('mp2');
      when the page loads. The results are the same.

      This seems to be the same problem as RF-2890 except this occurs this is on page load. http://jira.jboss.com/jira/browse/RF-2890?page=all

      Another issue I have seen is that
      left="auto"
      does not work on page load, but works fine when showing the modalPanel at other times.

      I am using RichFaces 3.2.0.SR1.

      <rich:modalPanel id="mp2" autosized="true" left="auto" top="10" resizeable="false" zindex="2000" showWhenRendered="true">
       <f:facet name="header">
       <h:outputText value="Modal Panel Title" />
       </f:facet>
      
       <h:panelGrid>
       <a4j:form id="productLineOptionForm" ajaxSubmit="true" oncomplete="Richfaces.hideModalPanel('mp2')">
       <h:panelGrid columns="2">
       <h:outputLabel>Name:</h:outputLabel><h:inputText id="test1"/>
       <h:outputLabel>Value:</h:outputLabel><h:inputText id="test2"/>
       </h:panelGrid>
       <h:commandButton id="close" value="Close" />
       </a4j:form>
       </h:panelGrid>
       </rich:modalPanel>