1 Reply Latest reply on Dec 12, 2005 11:01 AM by Kabir Khan

    MDBs with descriptors ignoring jboss.xml configuration?

    Bobby Kennedy Newbie

      Hi all,

      I recently posted a question on whether it was possible ot combine the use of annotations and descriptors for MDBs (http://www.jboss.com/index.html?module=bb&op=viewtopic&t=73440), the answer was yes, check out the JBoss ejb3 dd test cases.

      I am looking at the dd-mdb test case and it appears to me that the EJB3 mdbs in this test case is not working correctly. The beans seem to apply the configuration in the ejb-jar.xml, but ignore the settings in the jboss.xml.

      For example, if you take a look at the QueueBean, according to the jboss.xml, it should be bound to the queue "queue/testQueue":

      <message-driven>
       <ejb-name>QueueBean</ejb-name>
       <configuration-name>Standard Message Driven Bean</configuration-name>
       <destination-jndi-name>queue/testQueue</destination-jndi-name>
      </message-driven>


      But when deployed, this configuration is ignored and a temporary queue "queue/QueueBean" is created and used as the bean's destination:


      2005-12-07 13:01:28,165 DEBUG [org.jboss.ejb3.mdb.MDB] Got destination type Queue for QueueBean
      2005-12-07 13:01:28,165 DEBUG [org.jboss.ejb3.mdb.MDB] jndiSuffix: QueueBean
      2005-12-07 13:01:28,165 DEBUG [org.jboss.jms.ConnectionFactoryHelper] using connection factory: org.jboss.mq.SpyXAConnectionFactory@1b8fcdd
      2005-12-07 13:01:28,166 DEBUG [org.jboss.jms.ConnectionFactoryHelper] using username/password: null/null
      2005-12-07 13:01:28,167 DEBUG [org.jboss.jms.ConnectionFactoryHelper] created XAQueueConnection: Connection@21790187[token=ConnectionToken:null/5b2d6e629775fb39ec3830bd92e9114c rcvstate=STOPPED]
      2005-12-07 13:01:28,167 DEBUG [org.jboss.ejb3.mdb.MDB] Using client id: null
      2005-12-07 13:01:28,168 WARN [org.jboss.ejb3.mdb.MDB] destination not found: queue/QueueBean reason: javax.naming.NameNotFoundException: QueueBean not bound
      2005-12-07 13:01:28,168 WARN [org.jboss.ejb3.mdb.MDB] creating a new temporary destination: queue/QueueBean



      Any thoughts on this? Am I doing something wrong, or is there indeed a problem with MDBs picking up the jboss.xml configuration? Any suggestions/workarounds?