0 Replies Latest reply on Mar 2, 2006 5:23 AM by Frank Cornelis

    NoClassDefFoundError by ServiceController

    Frank Cornelis Apprentice

      When JBoss is loading my EJB it gives me a NoClassDefFoundError when he tries to start the service jboss.j2ee:service=EJB3,module=my-model.jar.
      The funny thing is that the Class-Path inside the MANIFEST.MF of the EJB JAR is set correctly and the JAR containing the class lives inside my EAR.
      It seems like the ServiceController is using some reflection to load method dependencies, but with a classpath that is incorrect. Or am I doing something wrong here?

      11:18:05,966 WARN [ServiceController] Problem starting service jboss.j2ee:service=EJB3,module=my-model.jar
       [exec] java.lang.NoClassDefFoundError: the.class.name
       [exec] at java.lang.Class.getDeclaredMethods0(Native Method)
       [exec] at java.lang.Class.privateGetDeclaredMethods(Class.java:2365)
       [exec] at java.lang.Class.getDeclaredMethods(Class.java:1763)
       [exec] at org.jboss.ejb3.injection.PersistenceContextHandler.loadMethodDependencies(PersistenceContextHandler.java:244)
       [exec] at org.jboss.ejb3.injection.PersistenceContextHandler.loadDependencies(PersistenceContextHandler.java:348)
       [exec] at org.jboss.ejb3.EJBContainer.processMetadata(EJBContainer.java:239)
       [exec] at org.jboss.ejb3.Ejb3Deployment.processEJBContainerMetadata(Ejb3Deployment.java:406)
       [exec] at org.jboss.ejb3.Ejb3Deployment.start(Ejb3Deployment.java:457)
       [exec] at org.jboss.ejb3.Ejb3Module.startService(Ejb3Module.java:139)
      ...