2 Replies Latest reply on Mar 22, 2006 4:21 AM by Serge Emmanuel Pagop

    "Incomplete Deployment listing" Error with jboss-4.0.4RC1

    Michael Shpigel Newbie

      I've written a simple stateless session bean:


      @Stateless
      public class DALBean implements IDALLocal, IDALRemote
      {
       @PersistenceContext(unitName="blah")
       protected EntityManager em;
      
      
       public void addData()
       {
       // TODO Auto-generated method stub
      
       }
      
       public void updateData()
       {
       // TODO Auto-generated method stub
      
       }
      
       public void deleteData()
       {
       // TODO Auto-generated method stub
      
       }
      
       public Collection <Listing> selectData(int accountId)
       {
      
       }
      }

      I have also defined persistence.xml file in the META-INF folder:

      <?xml version="1.0" encoding="UTF-8"?>
      <xml-body>
      <persistence>
       <persistence-unit name="blah">
       <jta-data-source>java:/DefaultDS</jta-data-source>
       <properties>
       <property name="hibernate.hbm2ddl.auto"
       value="create-drop"/>
       </properties>
       </persistence-unit>
      </persistence>
      </xml-body>

      When I start JBoss 4.0.4RC1 I get the following error:

      22:07:30,956 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.j2ee:service=EJB3,jar=benchmarkejb3.jar,name=DALBean
      State: NOTYETINSTALLED
      I Depend On:
      persistence.units:unitName=blah

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: persistence.units:unitName=blah
      State: NOTYETINSTALLED
      Depends On Me:
      jboss.j2ee:service=EJB3,jar=benchmarkejb3.jar,name=DALBean

      Can you, please, help me with this!!!


        • 1. Re:
          Serge Emmanuel Pagop Newbie

          Hi,
          I have the same problem since yesterday. But I do not use JBoss-4.0.4RC1 AS to run my application. I use JBoss-EJB-3.0_Embeddable_ALPHA_5 and thus my error in the console of eclipse look like this:

          DEBUG 22-03 08:10:19,203 (KernelFactory.java:assembleNewKernel:86) -Starting JBoss Kernel construction...
          DEBUG 22-03 08:10:19,390 (KernelFactory.java:assembleNewKernel:112) -Completed JBoss Kernel construction. Duration: 187 milliseconds
          DEBUG 22-03 08:10:20,625 (BeanXMLDeployer.java:deploy:91) -Parsing file:/C:/dev/workspace/embedded-ejb3/bin/embedded-jboss-beans.xml took 1172 milliseconds
          DEBUG 22-03 08:10:20,953 (UserTransactionImpl.java:start:61) -new UserTx: org.jboss.ejb3.embedded.UserTransactionImpl@1a42792
          INFO 22-03 08:10:21,062 (LocalTxDataSource.java:bindConnectionFactory:117) -Bound datasource to JNDI name 'java:/DefaultDS'
          DEBUG 22-03 08:10:21,109 (BeanXMLDeployer.java:deploy:98) -Deploying file:/C:/dev/workspace/embedded-ejb3/bin/embedded-jboss-beans.xml took 1656 milliseconds
          DEBUG 22-03 08:10:21,812 (EJB3StandaloneBootstrap.java:createDeployer:266) -No MBeanServer
          DEBUG 22-03 08:10:21,859 (JaccHelper.java:initialiseJacc:61) -Initialising JACC Context for deployment: bin
          INFO 22-03 08:10:22,265 (Ejb3AnnotationHandler.java:getContainers:156) -found EJB3: ejbName=CustomerDAOBean, class=de.mathema.doa.beans.CustomerDAOBean, type=STATELESS
          DEBUG 22-03 08:10:22,437 (ProxyDeployer.java:initializeRemoteBindingMetadata:133) -no declared remote bindings for : CustomerDAOBean
          INFO 22-03 08:10:22,468 (Ejb3Deployment.java:create:444) -EJB3 deployment time took: 609
          DEBUG 22-03 08:10:22,531 (JaccHelper.java:initialiseJacc:61) -Initialising JACC Context for deployment: jboss-serialization
          INFO 22-03 08:10:22,734 (Ejb3Deployment.java:create:444) -EJB3 deployment time took: 203
          DEBUG 22-03 08:10:22,750 (JaccHelper.java:initialiseJacc:61) -Initialising JACC Context for deployment: ehcache
          INFO 22-03 08:10:22,812 (Ejb3Deployment.java:create:444) -EJB3 deployment time took: 62
          DEBUG 22-03 08:10:22,812 (JaccHelper.java:initialiseJacc:61) -Initialising JACC Context for deployment: META-INF
          INFO 22-03 08:10:22,812 (Ejb3Deployment.java:create:444) -EJB3 deployment time took: 0
          DEBUG 22-03 08:10:22,812 (JaccHelper.java:initialiseJacc:61) -Initialising JACC Context for deployment: jboss-xml-binding
          INFO 22-03 08:10:23,281 (Ejb3Deployment.java:create:444) -EJB3 deployment time took: 469

          Exception in thread "main" java.lang.RuntimeException: Problems scanning classpath
          at org.jboss.ejb3.embedded.EJB3StandaloneBootstrap.scanClasspath(EJB3StandaloneBootstrap.java:245)
          at de.mathema.doa.beans.Main.main(Main.java:32)

          DEBUG 22-03 08:10:23,375 (EJBContainer.java:initialiseInterceptors:708) -Initialising interceptors for CustomerDAOBean...
          DEBUG 22-03 08:10:23,375 (EJBContainer.java:initialiseInterceptors:710) -Default interceptors: null
          DEBUG 22-03 08:10:23,375 (EJBContainer.java:initialiseInterceptors:713) -Class interceptors: []
          DEBUG 22-03 08:10:23,375 (EJBContainer.java:initialiseInterceptors:729) -All applicable interceptor classes: []
          INFO 22-03 08:10:23,375 (MCKernelAbstraction.java:install:79) -installing bean: jboss.j2ee:service=EJB3,jar=bin,name=CustomerDAOBean with dependencies:
          INFO 22-03 08:10:23,390 (MCKernelAbstraction.java:install:82) - AbstractDependencyMetaData@5976c2{dependency=persistence.units:unitName=custdb}
          DEBUG 22-03 08:10:23,421 (Ejb3Deployment.java:registerEJBContainer:415) -Bound ejb3 container jboss.j2ee:service=EJB3,jar=bin,name=CustomerDAOBean
          ERROR 22-03 08:10:23,437 (KernelErrors.java:validate:107) -
          *** DEPLOYMENTS MISSING DEPENDENCIES:
          jboss.j2ee:service=EJB3,jar=bin,name=CustomerDAOBean depends on:
          persistence.units:unitName=custdb'{Create:NOT FOUND}
          persistence.units:unitName=custdb'{Start:NOT FOUND}

          • 2. Re:
            Serge Emmanuel Pagop Newbie

            I know yet where my problem was. I seem from the brginning that the PersistenceXmlLoader does not find the persistence.xml file. This means you have to make sure that the persistence.xml is in the classpath located.