2 Replies Latest reply on Apr 4, 2006 9:40 PM by apdo

    deploy EJB3.0 with EJB2.1

    apdo Newbie

      I would like to migrate to EJB3.0 an application already written with EJB2.1.

      I have maybe done something wrong but I have not been able to deploy a statfull session bean EJB3.0 with my exising EJBs 2.1.

      when I add my new statefull session bean EJB3.0 into the .ear and I deploy it, jboss try to deploy all entity bean 2.1 as ejb 3.0:
      example:
      2006-04-03 12:58:41,088 INFO [org.jboss.ejb3.Ejb3AnnotationHandler] found EJB3: ejbName=TaskPermission, class=com.solabs.alibaba.pma.TaskPermissionBean, type=ENTITY

      also I got the following stacktrace:
      java.lang.ClassNotFoundException: No ClassLoaders found for: byte[]
      at org.jboss.mx.loading.LoadMgr3.beginLoadTask(LoadMgr3.java:292)
      at org.jboss.mx.loading.RepositoryClassLoader.loadClassImpl(RepositoryClassLoader.java:475)
      at org.jboss.mx.loading.RepositoryClassLoader.loadClass(RepositoryClassLoader.java:377)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      ...



      My overall question is: Is deploying entity 3.0 with entities 2.1 in the same ear file supposed to be possible? If not, is there a workaround or do we need to migrate every EJB to make it work.

      thank you very much,

      Phong